Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

No valid offer received: WDS PXE-E16 error when booting clients

Posted on 25/08/202003/09/2026 Christian By Christian 2 Comments on No valid offer received: WDS PXE-E16 error when booting clients
  1. Home
  2. Windows Server
  3. No valid offer received: WDS PXE-E16 error when booting clients
A diagram illustrating the process of Windows Deployment Services (WDS) leading to Virtual Machines (VMs) on a blue Windows background.

Windows Deployment Services (WDS) is the revised version of Remote Installation Services (RIS). WDS enables the deployment of new clients with a network-based installation without requiring that administrators visit each computer or install directly from CD or DVD media. For how to set up and install WDS role, and how to configure Windows Deployment Services on Windows Server 2019. Also, see how to configure Windows Deployment Services on Windows Server 2019. In this article, you will learn how to fix the “No valid offer received: WDS PXE-E16 error when booting clients”.

When prompted with this error below, as I always say, there are many factors that can be responsible for this.

Boot screen displaying PXE boot status with message indicating no valid offer received, under Hyper-V environment.

Below is what I did to resolve my issue. Please see How to remove Windows Deployment Services role via the GUI and PowerShell, and how to fix WinRM cannot complete the operation, verify that the specified computer name is valid.

Solution

The solution to fixing no valid offer received: WDS PXE-E16 error when booting clients. Ensure the Windows Deployment Server Services are running. To verify this, log on to the WDS Server, and launch the Windows Deployment Services Tool.

Screenshot of Windows Deployment Services interface showing the Active Directory Prestaged Devices section with options for removing a server and starting services.

The Windows Deployment Services have started successfully.

Notification window indicating successful start of Windows Deployment Services.

There are numerous reasons why this error is prompted. If the solution discussed above does not resolve your issue, kindly visit WDS PXE-E16 error when booting UEFI clients to see if what they discussed about this error can help you resolve your issue.

Right-click on the server, select “All Tasks” and click on Start. Please see What are the differences between MDT and WDS?, and how to fix “The service could not be started either because it is disabled or because it has no enabled devices associated with it.“

Optional: WDS moved to a different Subnet prompts PXE-E16 error

The PXE bootstrap broadcasts a DHCPDISCOVER packet with PXE-specific options on UDP port 67, which is not usually routed. Because of this, the PXE server must be located on the same subnet. But when in a different subnet, you must configure your network for forwarding UDP traffic via any of the following steps below;

  • Multihome the WDS server via additional NICs (or VLAN tagging via a single NIC if your NIC and switch support it) or,
  • Configure your network to forward UDP broadcasts. First set up the IP helper/DHCP relay on the router that communicates between the networks. For Cisco IOS this is done using the IP helper-address command.

If the DHCP server and WDS are in a different subnet now. You will also have to configure the DHCP options 66 and 67. I would recommend taking a look at WDS and DHCP Deployment Scenarios: Configure DHCP Options 60, 66, and 67

Please see how to fix Stuck at Start PXE over IPv4: PXE-E18, Server response timeout, resolve MDT Warning: Unable to set working directory, the application returned an unexpected code 2. Also, see What happens when WDS and DNS are installed on the same Windows Server? DNS issues with WDS.

I hope you found this blog post helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:WDS, WDSUTIL, Windows 10, Windows Server 2016

Post navigation

Previous Post: How to query a list of installed programs in Windows
Next Post: The service could not be started either because it is disabled or because it has no enabled devices associated with it

Related Posts

  • Screenshot 2020 05 19 at 18.54.21
    Unable to find File Explorer in the Group Policy Editor when resolving the security tab missing under properties Windows Server
  • dasfdg
    Unable to execute: The application GUID not found in the application list Windows Server
  • ACE magic
    How to install Windows Server unto ACEMAGICIAN Mini PC Windows Server
  • WinPE
    How to uninstall and upgrade ADK, WinPE, and MDT Windows Server
  • 1 WeXxkEX0JG3oB781HD8Hrg 3
    Fix Access denied to the hard drive, and the security tab missing under properties Windows Server
  • Windows Admin Center v2511
    How to upgrade Windows Admin Center from v2411 to v2511 Windows Server

More Related Articles

Screenshot 2020 05 19 at 18.54.21 Unable to find File Explorer in the Group Policy Editor when resolving the security tab missing under properties Windows Server
dasfdg Unable to execute: The application GUID not found in the application list Windows Server
ACE magic How to install Windows Server unto ACEMAGICIAN Mini PC Windows Server
WinPE How to uninstall and upgrade ADK, WinPE, and MDT Windows Server
1 WeXxkEX0JG3oB781HD8Hrg 3 Fix Access denied to the hard drive, and the security tab missing under properties Windows Server
Windows Admin Center v2511 How to upgrade Windows Admin Center from v2411 to v2511 Windows Server

Comments (2) on “No valid offer received: WDS PXE-E16 error when booting clients”

  1. Avatar photo Rashid says:
    10/05/2023 at 8:28 AM

    I feel like DHCP is also installed on that server and both WDS and DHCP trying to use same port 67
    check on cmd
    Text

    netstat -ano | findStr "67"
    

    If yes,
     Method 1At the command prompt, type the following command, and then press ENTER:
    wdsutil /set-Server /UseDhcpPorts:No
    Method 2Click Start, click Run, type wdsmgmt.msc, and then press OK.In the Windows Deployment Services window, expand Servers, right-click the WDS server name, and then click Properties.
    In the Server Properties dialog box, click the DHCP tab.
    Click to select the Do not listen on port 67 check box, and then click Apply.

    Log in to Reply
    1. chris Christian says:
      10/05/2023 at 8:00 PM

      Hello Rashid,

      Thank you very much for sharing this information with the community. As I mentioned, here is another possible solution to this issue.

      Cheers!

      Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • http trace fiddler
    How to Disable HTTP TRACE Method for Apache, IIS, sunOne, and Lotus Domino Web Server
  • Azure CI CD Pipeline
    CI/CD Pipeline: Your First in Azure DevOps with ASP.Net Core AWS/Azure/OpenShift
  • Featured image
    How to Disable or Uninstall OneDrive on Windows 10 and 11 Backup
  • How to Install SonarQube on Ubuntu LTS
    How to Install SonarQube on Ubuntu 20.04 LTS Network | Monitoring
  • multcloud
    Best Way to Backup Dropbox to Box Reviews
  • Featured image change default mail app
    How to change Windows 11 and 10 default mail app to Outlook Windows
  • image
    How to start HyperV VMs in safe mode Virtualization
  • S3 Bucket 1
    How to delete AWS S3 Bucket and Objects via  AWS CLI from Linux AWS/Azure/OpenShift

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.