Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

The service could not be started either because it is disabled or because it has no enabled devices associated with it

Posted on 28/08/202003/09/2026 Christian By Christian No Comments on The service could not be started either because it is disabled or because it has no enabled devices associated with it
  1. Home
  2. Windows Server
  3. The service could not be started either because it is disabled or because it has no enabled devices associated with it
Service startup issues

Windows Deployment Services (WDS) is a Microsoft tool for deploying Windows Operating System (OS) over the network. In Windows Server 2003, it was referred to as Remote Installation Services (RIS). The purpose of WDS is to remotely deploy the Windows operating system. WDS uses a PXE method for booting clients. Please see Program startup: How to launch an application automatically during startup on Windows, and how to fix “The virtual machine ran into a non-fatal problem as described below, we suggest that you take appropriate action to prevent the problem from recurring“.

In this article, we shall discuss “The service could not be started either because it is disabled or because it has no enabled devices associated with it”.

PXE enables clients to boot off the network. To find WDS services and to load boot images, the client should be able to contact the WDS server, and the client network card must be PXE compliant and most devices are NICs complaint.

See this guide on how to set up and install the WDS role, and how to configure Windows Deployment Services on Windows Server 2019. Also, see how to configure DHCP Server option 60, 66, and 67 for Windows Deployment Services.

Service Startup Issue Disabled or No Enabled Devices

The Windows Deployment Services are used for the central distribution of operating systems. Please visit the following link for more information on WDS not referenced here.

Disabled service error

When faced with this error “The Service Startup Issue Disabled or No Enabled Devices because it is disabled“.

However, when starting a WDS server, as shown below, please follow the suggested steps. See the following similar error “No valid offer received: WDS PXE-E16 error when booting UEFI and BIOS clients“.

Screenshot of Windows Deployment Services interface showing the 'All Tasks' menu with 'Start' option highlighted.

Furthermore, To fix this issue, you must ensure the Windows Deployment Services (services.msc)is started (running).

Note: This is applicable to all windows services regardless of the application.

You may want to see: How to start an application automatically on Mac. Also, see Uninstall WDS: How to remove Windows Deployment Services role via the GUI and PowerShell“.

I hope you found this blog post about addressing the Service Startup Issue Disabled or No Enabled Devices helpful. Please let me know in the comment session if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:WDS, Windows 10

Post navigation

Previous Post: No valid offer received: WDS PXE-E16 error when booting clients
Next Post: How to setup SELinux on a Linux server

Related Posts

  • qAS
    How to disable the Microsoft Deployment Toolkit Task Sequence property sheet Windows Server
  • screenshot 2020 03 31 at 22.22.43
    How to create, edit and delete a scheduled task via the Command Prompt Windows Server
  • article 1280x720.192a2586 1 1
    How to install WSL on Windows Server Windows Server
  • Key distribution center
    Perform Key Distribution Center Service [krbtgt] Password reset Windows
  • How To Upgrade Windows 11 Pro to Enterprise
    Upgrade Windows 11 Pro to Enterprise and vice Versa Windows
  • 33
    The wim file needs to be remounted: Fix error 0xc1510114 Windows Server

More Related Articles

qAS How to disable the Microsoft Deployment Toolkit Task Sequence property sheet Windows Server
screenshot 2020 03 31 at 22.22.43 How to create, edit and delete a scheduled task via the Command Prompt Windows Server
article 1280x720.192a2586 1 1 How to install WSL on Windows Server Windows Server
Key distribution center Perform Key Distribution Center Service [krbtgt] Password reset Windows
How To Upgrade Windows 11 Pro to Enterprise Upgrade Windows 11 Pro to Enterprise and vice Versa Windows
33 The wim file needs to be remounted: Fix error 0xc1510114 Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • mssql ubuntu install feature image
    How to reset MSSQL Server SA Password on Ubuntu Oracle/MSSQL/MySQL
  • asdfgh
    All Group Policies (GPO) available to configure Microsoft Edge settings Windows Server
  • Screenshot 2022 02 25 at 02.06.20
    How to install SAMBA file shares for Servers and Clients Linux
  • mysqlhero
    How to reset MySQL Root password Oracle/MSSQL/MySQL
  • integrate VHR with VBR
    How to deploy and integrate VHR with VBR Backup
  • Prevent the saving of RDP Credentials
    Prevent users from saving RDP Credentials on Windows 11 Windows
  • mountedimagenotaccessible
    Unable to access the image: Make sure that the image path exist Windows
  • hh
    Graphical Network Simulator: How to install GNS3 on a Windows device Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.