Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Perform Pleasant Password Self-serve Reset using the “link”

Posted on 03/01/202017/08/2026 Christian By Christian No Comments on Perform Pleasant Password Self-serve Reset using the “link”
  1. Home
  2. Virtualization
  3. Perform Pleasant Password Self-serve Reset using the “link”
Password reset

In this article, we shall discuss how to Perform Pleasant Password Self-serve Reset using the “link for users who have forgotten their password”. The Pleasant Password Manager is a robust tool for managing passwords securely and conveniently. Its comprehensive features make it suitable for businesses looking to enhance their security posture and streamline password management. Please see How to reset your lost or forgotten Windows 10 Password, and How to import Users and Groups into Pleasant Password Manager.

More specifically, the Pleasant Password Manager (PPM) is a password management tool designed to help users securely store, manage, and organize passwords.

It offers a range of features to improve security and usability for both individuals and organization usage.

Please see How To Use Pleasant Password Private Folder, and How to Perform a Self-service Password Reset using the Windows Login Integration Client. Also, see IP Address blocked on Synology NAS due to forgotten Password.

Pleasant Password Self-serve Reset

This functionality is vital if you wish to have your password changed using the web browser.

Here are the steps below. Click on Forgot Password link

Self-service

Ignore the certificate warning and proceed to the webpage. This will display the Forgot Password Window as shown below.

Perform Pleasant Password Self-serve Reset

Forgotten password

Enter your Domain User name as shown above and click on Request Password Reset. Enter your Answers to the Security Questions displayed as shown below

Forgotten password

Note: This step might be displayed one after the other or listed at once.

Either way, just answer each question and click save to display the next question.

And Click on Save. The two Factor Provider Window is displayed, click on save as shown below.

User authentication

This will prompt and request the Authentication Application Token as shown below. Enter the Token displayed on from your Authentication App and click on submit.

Password reset

This will display a new window where your new password can be entered and changed(Perform Pleasant Password Self-serve Reset).

Enter the new password and click on change password. If successful, this will display the window below.

Notification indicating successful password reset with a green background and a button to close the window.

I hope you found this article very useful on how to “Perform Pleasant Password Self-serve Reset using the “link for users who have forgotten their password”. Please feel to leave a comment below.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization

Post navigation

Previous Post: How to Perform a Self-service Password Reset using the Windows Login Integration Client
Next Post: Windows Single or Multi App Kiosks

Related Posts

  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
  • upgrade proxmox node e1781352297373
    How to update Proxmox VE to the latest version 9.2.3 today Virtualization
  • Error 401 Permission denied for invalid PVE ticket
    How to fix Error 401 Permission denied for invalid PVE ticket Virtualization
  • image 25
    ESXI 6.7 ALARM: Seat disk exhaustion on 10 Virtualization
  • Fix this PC cannot run Windows 11
    Bypass unsupported CPU and Processor by upgrading to Windows 11 via Windows Update Virtualization
  • Clone SysPrep
    Clone and Sysprep a Windows Server running on a VMware Workstation Virtualization

More Related Articles

OpenShift DR Hero e1784641900398 Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
upgrade proxmox node e1781352297373 How to update Proxmox VE to the latest version 9.2.3 today Virtualization
Error 401 Permission denied for invalid PVE ticket How to fix Error 401 Permission denied for invalid PVE ticket Virtualization
image 25 ESXI 6.7 ALARM: Seat disk exhaustion on 10 Virtualization
Fix this PC cannot run Windows 11 Bypass unsupported CPU and Processor by upgrading to Windows 11 via Windows Update Virtualization
Clone SysPrep Clone and Sysprep a Windows Server running on a VMware Workstation Virtualization

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Featured image WSL2 installation
    How to install WSL2 on Windows Server Linux
  • Reset folder view settings on File Explorer for Windows 11 and 10
    Reset folder view settings on File Explorer for Windows 11 and 10 Windows
  • Update Wampserver
    How to update WampServer to Latest Version Web Server
  • TLS1.2
    Unable to install Azure AD Connect, TLS 1.2 is required: How to enable or disable TLS 1.2 on a Windows Server via the Registry and PowerShell AWS/Azure/OpenShift
  • Account restrictions are preventing this user from signing in
    Resolve Account restrictions are preventing this user from signing in: User Account Password has expired Windows
  • Screenshot 2020 11 17 at 12.20.15
    PA Server Monitor Ultra: How to setup PA Server Monitor Reviews
  • SUID GUID Sticky Bit 1
    Set Special File Permissions with SUID or GUID and Sticky Bit Linux
  • Why you should not Upgrade Windows on an ePO Server
    Why you should not Upgrade Windows on an ePO Server Windows Server

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.