Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Error 1064: An exception occurred in the service when handling the control request

Posted on 24/02/202216/08/2026 Christian By Christian No Comments on Error 1064: An exception occurred in the service when handling the control request
  1. Home
  2. Backup
  3. Error 1064: An exception occurred in the service when handling the control request
veeam

Veeam Backup & Replication is a comprehensive data protection and disaster recovery solution. It provides a centralized console for administering backup, restore, and replication operations in all supported platforms (virtual, physical, and cloud). In this article, we shall discuss “Error 1064: An exception occurred in the service when handling the control request”. Please see How to uninstall Git from MacOS, and how to fix Cannot find the computer: Fix the following error occurred while using Kerberos authentication.

Regardless of what your needs are ranging from flexible hybrid cloud capabilities from AWS, Azure, and Google Cloud, or the most robust ransomware protection and recovery options.

Kindly refer to these related guides: Veeam Certified Architect: A review of the VMCA Training & Certification, and how to set up Veeam ONE 11 Server. Also, see how to uninstall Veeam Backup and Replication from your server, and how to set up Veeam Backup for Microsoft Azure [Part 1].

Here is the Eror message "Error 1064: An exception occurred in the service when handling the control request: No connection can be made because the active machine rejected it".

Why use Veeam?

Veeam brings hardened immutable storage options, dependable cloud-native backup options, and Continuous Data Protectio. Much more all under one platform, with a single portable license for all workloads.

The following is a related error “Failed to connect to Veeam Backup & Replication Server: No connection could be made because the target machine actively refused it“. Even when you try to start the service, it does not start and it fails with the following error.

Error 1064-1
Error 1064

Reason for the error

This is because the evaluation period of 180 days has expired. Kindly refer to this guide on MSSQL licensing: How to upgrade SQL Server instance.

Also, I decided to take a look at the log as shown below. Microsoft Windows servers, logs are stored in the following directory: %ProgramData%\Veeam\Backup. On a Linux machine, and ESXi hosts, logs are stored in the following directory: /var/log/VeeamBackup/ or /tmp/VeeamBackup.

Screenshot-2022-02-24-at-23.12.23
[21.02.2022 21:59:45] <04> Info [DB] Connecting to SQL Server (CurrentUser=[TECHDIRECTARCHI\Christian], ServerInstance=[MBAMSERV1\MBAM], Options=[Direct])
[21.02.2022 21:59:45] <04> Info [DB] Removing 'Initial Catalog' property from connection string
[21.02.2022 22:01:45] <04> Info [DB|ERROR] Failed to connect to server . (Microsoft.SqlServer.Management.Common.ConnectionFailureException)
[21.02.2022 22:01:45] <04> Info [DB|ERROR] at Microsoft.SqlServer.Management.Common.ConnectionManager.Connect()
[21.02.2022 22:01:45] <04> Info [DB|ERROR] at Veeam.Backup.DBCreator.DatabaseConnector.Connect(DatabaseConnectorOptions options)
[21.02.2022 22:01:45] <04> Info [DB|ERROR] A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (System.Data.SqlClient.SqlException)

As you can see below, the SQL Server service isn’t running.

start sql server service

Upon resolving this issue by upgrading the SQL Server instance. I was now able to start the service as shown below.

Kindly refer to these related guides: How to install MSSQL Server 2019 Developer Edition and SSMS on Windows, and how to download and install Microsoft SQL Server 2019 Express edition and SSMS.

sql server service is running

Yet, the Veeam Backup and Replication console could not be started with the following error “Failed to connect to the Backup and Replication Server - No connection can be made because the active machine rejected it".

Screenshot-2022-02-24-at-18.56.16

To fix these issues, you will need to grant the Veeam Backup Service local administrative rights. For me, the local system account did not work.

Set Service Account

Note: The account used to run the Veeam Backup Service must be a LocalSystem account. Or must have local Administrator permissions on the backup server.

Screenshot-2022-02-24-at-21.39.10

Upon granting these rights, I was able to start the Veeam Backup and Replication Console. The console allows you to automate and schedule routine data protection operations and integrate with solutions for alerting and generating compliance reports.

Also, see “Windows could not start the SQL Server service on local computer 17051: A network-related or instance-specific error occurred while establishing a connection to SQL Server“.

I hope you found this blog post on “Error 1064: An exception occurred in the service when handling the control request helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Backup Tags:Azure, HybridBackup, Image backup, Microsoft Windows, Veeam, Veeam Backup and Replication, Windows 10, Windows Server 2016, Windows Server Backup

Post navigation

Previous Post: Sudo Error on Ubuntu: Fixing ‘unknown uid 1000: Who are you?’
Next Post: Domain Name System: All you need to know about DNS

Related Posts

  • Veeam Data cloud VDC Enrollment
    A-Z on Veeam Data Cloud: Workload Enrollment and Onboarding Backup
  • Veeam SureBackup
    Ensuring Backup Integrity and Reliable Recovery with SureBackup Backup
  • Object First Honeypot OOTBI
    OOTBI Security Best Practices: Enable Honeypot on Object First Backup
  • Backup is an attacker real target
    Hacker Thinking in Ransomware Attacks: Backup Is the real Target Backup
  • VBR upgrade to 13.1
    Strategic breakdown and step by step guide to upgrading to VBR 13.1 Backup
  • ransoware recovery strategy
    What Ransomware Recovery looks like when the clock is ticking Backup

More Related Articles

Veeam Data cloud VDC Enrollment A-Z on Veeam Data Cloud: Workload Enrollment and Onboarding Backup
Veeam SureBackup Ensuring Backup Integrity and Reliable Recovery with SureBackup Backup
Object First Honeypot OOTBI OOTBI Security Best Practices: Enable Honeypot on Object First Backup
Backup is an attacker real target Hacker Thinking in Ransomware Attacks: Backup Is the real Target Backup
VBR upgrade to 13.1 Strategic breakdown and step by step guide to upgrading to VBR 13.1 Backup
ransoware recovery strategy What Ransomware Recovery looks like when the clock is ticking Backup

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • screenshot 2020 02 13 at 22.47.41
    Active Directory Flexible Single-Master Operations Roles [FSMO] Windows Server
  • fhgjk
    Replicating MDT Deployment Share: How to Create a Selection Profile and Link MDT Deployment Shares Windows Server
  • UpdateOfficeOnlineServer 1
    Perform Office Online Server Update via the Microsoft Update Catalog Network | Monitoring
  • Internet Explorer
    How to uninstall Internet Explorer from your Windows Device Windows
  • DC creation as recommended by Microsoft
    Setup a Domain Controller as Recommended by Microsoft Windows Server
  • windows hello la gi
    All you need to know before deploying Windows Hello for Business Key and Certificate Trust Windows
  • What Happens if You Turn Off Your Computer During windows update
    What Happens if You Turn Off Your Computer During an Update Windows
  • sign11
    Windows sign-in options and account protection on Windows 11 Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.