Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Error – Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode

Posted on 31/07/201917/08/2026 Christian By Christian No Comments on Error – Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode
  1. Home
  2. Network | Monitoring
  3. Error – Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode
Encapsulationset to Auto

In this article, we shall discuss the fix for “Error – Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode”. The error message is prompted when you attempt to configure an interface to trunk mode. While its encapsulation is set to “Auto.” This happens when the switch cannot determine the encapsulation method (IEEE 802.1Q or ISL) for the trunk link. Please see How to disable auto login in Windows, and how to Disable or Enable Auto log on in Windows.

Also, see how to Fix “Error 1064: An exception occurred in the service when handling the control request“, and Auto Logon Error “Username and password specified is not valid”. Here is “Disable SQL Auto Close: Auto Close is enabled for both ePO and ePO Events Databases“.

Reason for the error

As you can see below, the error is prompted. This is because, you will need to explicitly set the trunk encapsulation before configuring the interface to trunk mode.

switch(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode.

This is a result of a missing encapsulation command type (That is 802.1Q on that port). Follow the steps below to fix this “Command Rejected” error message.

Set the Encapsulation Type

Before setting the interface to trunk mode, you need to specify the encapsulation type. Enter the interface configuration mode and enter the following command below

switch(config-if)#switchport trunk encapsulation dot1q

Before proceeding with the rest configuration. You can now set the port as a trunk without any issue.

Configure the Interface as Trunk

switch(config-if)switchport mode trunk

Exit the interface configuration mode and save the changes.

exit
write memory # Save the configuration

For other guides, see: How to clear Cache and Manually Update Microsoft Defender, How to fix: This network connection does not exist and Reveal the WiFi password of the Network you are connected to in Windows.

I hope you found this blog post on fixing this “Error – Command rejected: An interface whose trunk encapsulation is “Auto” can not be configured to “trunk” mode” helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Network | Monitoring

Post navigation

Previous Post: How to disable web console in Cisco switches
Next Post: Security Best Practice to secure your Cisco Router and Switches

Related Posts

  • tape cleaning e1778595685861
    How to perform Tape Drive Cleaning in Practice Network | Monitoring
  • RemoteDesktopLinceseServer
    Fix Remote session was disconnected because there are no Remote Desktop License Servers available to provide a license Network | Monitoring
  • Install Windows Admin Center on Windows Server 2019
    Configure Windows Admin Center on Windows Server 2019 Network | Monitoring
  • amazon ec2 multiple ips 1
    What to note before assigning Multiple IPs’ to an Instance AWS/Azure/OpenShift
  • screenshot 2020 04 07 at 02.14.53
    SSH and Telnet on Cisco ASA 5505: Quick Setup Guide Network | Monitoring
  • Exchange Admin Centre EMC
    How to grant Access to User Mailbox Network | Monitoring

More Related Articles

tape cleaning e1778595685861 How to perform Tape Drive Cleaning in Practice Network | Monitoring
RemoteDesktopLinceseServer Fix Remote session was disconnected because there are no Remote Desktop License Servers available to provide a license Network | Monitoring
Install Windows Admin Center on Windows Server 2019 Configure Windows Admin Center on Windows Server 2019 Network | Monitoring
amazon ec2 multiple ips 1 What to note before assigning Multiple IPs’ to an Instance AWS/Azure/OpenShift
screenshot 2020 04 07 at 02.14.53 SSH and Telnet on Cisco ASA 5505: Quick Setup Guide Network | Monitoring
Exchange Admin Centre EMC How to grant Access to User Mailbox Network | Monitoring

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • image 77
    How to use the DigiCert certificate utility for Windows to create a CSR Windows
  • spell
    Disable Cloud-Based Spell Checker in Microsoft Edge and Google Chrome Windows
  • How To Backup Your WordPress Database banner
    How to Backup and Restore your WordPress Files and Database Backup
  • 2019Blacklist Blog
    How does IP Address or Domain blacklist work? Network | Monitoring
  • Featured image Teams Whiteboard
    How to use Whiteboard in Microsoft Teams meetings Windows
  • Best Disk Partition Manager for Mac
    How to extend System Drive Partition on Windows Windows
  • ackup Repository and Add HyperV to VBR Inventory
    Create local Backup Repository and Add HyperV to VBR Inventory Backup
  • Featured image 2
    5 Steps to Fix Outlook continually prompts for passwords Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.