Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

How to add a second Domain Controller

Posted on 08/01/202017/08/2026 Christian By Christian No Comments on How to add a second Domain Controller
  1. Home
  2. Windows Server
  3. How to add a second Domain Controller
Logo of Active Directory with text 'Additional Domain Controller' on a blue background.

A domain controller (DC) is a server computer that responds to authentication requests. It participates in the replication and contains a complete copy of all directory information for their domain. If your environment requires high availability of IT systems when one DC fails, another takes over to ensure successful login, etc. Please see this guide for how to set up VMs in Hyper in order to have Domain Controllers running on Virtual Machines, and “Post OS configure Windows Server 2019 Properties, and how to Setup and configure a DC. In this article, you will learn how to add a second Domain Controller.

If you wish to install an additional domain controller to balance the load and increase fault tolerance. This how-to guide describes the steps needed to add a domain controller to your existing Active Directory (AD) environment.

Also, see How to add a new Domain Controller to an Existing Domain, How to setup a Third-Party DNS Server on a Linux Server, and how to Setup a Domain Controller as Recommended by Microsoft.

Add a second Domain Controller

Kindly follow the steps discussed below to add an additional DC to your domain. You will have to install the AD DS role and promote it as a Domain Controller.

Add a domain controller into an existing domain
Screenshot of a deployment configuration interface, highlighting the option to add a domain controller to an existing domain, with fields for domain information and credentials.

Note: You can decide to join this server to the domain before promoting it as a domain controller.

But in my case, I did not join the second Domain Controller to the domain previously. Because, when adding a new domain controller into an existing domain, this action will be performed by default.

If you previously joined the Server to the Domain before promoting it, it will move the computer object out of the computer OU to the Domain Controller OU (Container) Next click on Change to enter the credential needed to join the domain.

Windows Security dialog box prompting for user credentials with fields for 'User name' and 'Password' highlighted.

You may encounter an error in this stage if you are using the default administrator account.

Create a new account and add the user as a member of the domain Administrator. This works! Remember to uncheck the Domain Name System Here (DNS) server. We do not need it as there is an existing DNS server.

Screenshot of the Domain Controller Options setup page, highlighting settings for DNS server, Global Catalog, and Read-Only Domain Controller. Fields for site name and DSRM password are visible.

Please see Fix Outlook Not Responding and Outlook Crashing or freezing, Domain Join: How to join a computer to the Domain, and how to fix “Error: An Active Directory could not be contacted or cannot find domain because it is nonexistent“.

Specify Replication Server

Under Additional Options, select “Replicate from” using the drop-down button to specify the DC to replicate from.

Screenshot of the 'Additional Options' section in a software installation wizard, highlighting the 'Replicate from:' dropdown menu with the option 'Any domain controller'.

Under paths, you can decide to store them in a different location as best practice. I will leave them as default.

Screen displaying the 'Paths' setup for Active Directory Domain Services installation, showing options for database, log files, and SYSVOL folders with navigation buttons.

Under the review Option, click on next as this gives you an opportunity to review what you have done.

Here it will perform the prerequisite checks and if it passes, it will prompt you to install Active Directory Domain Services.

Screenshot of the Windows Server 2019 prerequisites check for Active Directory Domain Services, indicating that all checks passed successfully and prompting the user to click 'Install' to begin installation.

After installation, the computer will reboot. Now both DCs are global catalogs and can respond to user queries.

A computer interface displaying a list with two entries labeled 'Computer' under the 'Type' column and 'GC' under the 'DC Type' column, with 'GC' highlighted in yellow.

That is all 🙂 Verify the replication from Active Directory Sites and Services. I will be blogging on how to perform manual replication and testing if replication works. Keep an eye on this site for this.

Please see how to fix “The trust relationship between this workstation and the primary domain failed“, how to Integrate TestRail with Cypress, and how to Fix Python was not found run without arguments to install from the Microsoft Store.

I hope you found this blog post helpful on how to add a second Domain Controller. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Active Directory, DC, Domain, Domain Controller

Post navigation

Previous Post: How to change the Default First-Site-Name in Active Directory
Next Post: WordPress site on Azure: How to create a website hosted in Azure

Related Posts

  • connect to RDP automatically
    RDP Configuration Settings: Connect automatically to RDP session Windows
  • RDS Collection 1
    How to add and remove RDS Collection Windows
  • powershell01
    How to add servers to the Trusted Hosts list Scripts
  • Fixed drives not encrypted by BitLocker via MBAM
    Why is BitLocker unable to encrypt Removable Drives via MBAM? Windows
  • fgh
    Configure log on as a batch job permissions on any server Windows Server
  • Zit error e1774460375104
    How to fix Domain Join Error during Windows Deployment Windows Server

More Related Articles

connect to RDP automatically RDP Configuration Settings: Connect automatically to RDP session Windows
RDS Collection 1 How to add and remove RDS Collection Windows
powershell01 How to add servers to the Trusted Hosts list Scripts
Fixed drives not encrypted by BitLocker via MBAM Why is BitLocker unable to encrypt Removable Drives via MBAM? Windows
fgh Configure log on as a batch job permissions on any server Windows Server
Zit error e1774460375104 How to fix Domain Join Error during Windows Deployment Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Trellix Invalid credential
    Fix unable to login to Trellix ePO with Windows authentication Windows Server
  • MBAM Client
    How to Check if MBAM Agent is installed on Windows PC Windows
  • nonRDP admin
    Allow RDP access for non administrators: Add User to Remote Desktop Users Group in Active Directory Windows Server
  • screensaver1
    Prevent Windows Users from Changing the Screen Saver via the Registry Settings Windows
  • ERRORFEATURE
    Fix 404 Not Found Repository Errors in Ubuntu/Debian distribution Linux
  • Featured image 1
    Add and Remove Folders in Favorites in Microsoft Outlook Windows
  • dfg
    DISM failed with error 0x800f081f: Source file could not be found Windows Server
  • NFS Storage and Present it to XCP ng
    Create an NFS Storage on Synology NAS and Present it to XCP-ng Virtualization

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.