Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

The validation process found problems on the server to which you want to install features, the features are not compatible with the current configuration of your server

Posted on 07/07/202122/08/2026 Christian By Christian 2 Comments on The validation process found problems on the server to which you want to install features, the features are not compatible with the current configuration of your server
  1. Home
  2. Virtualization
  3. The validation process found problems on the server to which you want to install features, the features are not compatible with the current configuration of your server
Server compatibility issues

In this article, we shall discuss how to fix “The validation process found problems on the server to which you want to install features, the features are not compatible with the current configuration of your server”. You may want to see these troubleshooting guides too: Windows failed to start, a recent hardware or software change might be the cause: VMware Status code 0xc000014c, the boot configuration data for your PC is missing or contains errors, Taking ownership of a VM failed: The virtual machine appears to be in use.

VMware Workstation Pro is the industry standard for running multiple operating systems as virtual machines (VMs) to build, test software. IT professionals, developers, and businesses who build, test software for any device, platform, or cloud rely on Workstation Pro.

VMware Workstation Pro allows you to run multiple virtual machines, OCI containers, and Kubernetes clusters at once on the same Windows or Linux PC.

Create fully featured and securely isolated Linux and Windows VMs and other desktop servers, and cloud environments. With complete with configurable virtual networking and network condition simulation, for use in code development, solution architecting, application testing, product demonstrations, and more.

Below are some related guides: How to install Windows Server 2022 on VMware Workstation, how to extend a VM’s Hard Disk on VMware Workstation, and Boot failure: Fix EFI network timeout on VMware Workstation.

Virtualize Intel VT-x/EPT or AMD-V/RVI:

You may be unable to add the HyperV role onto your server that is running on VMware WorkStation. Kindly refer to the following error below. This error was prompted because the virtualize intel vt-x/ept or amd-v/rvi for the Server was not enabled.

Workstation Pro forces the virtual machine execution mode to VT-x/EPT or AMD-RVI. You must enable Physical Address Extension (PAE) mode to use virtualized AMD-V/RVI.

If the host system doesn’t support the execution mode, VT-x/EPT or AMD/RVI won’t be available. If you migrate the virtual machine to another VMware product, virtualized VT-x/EPT or AMD-V/RVI might not be available.

Hyper-V is a hypervisor-based virtualization technology and it uses the Windows hypervisor, which requires a physical processor with specific features. For hardware details, see System requirements for Hyper-V on Windows Server.

Feature installation problems

the virtual machine ran into a non-fatal problem as described below, we suggest that you take appropriate action to prevent the problem from recurring, how to solve VMware workstation .lck error, and how to add and remove a new virtual disk from a VM on VMware Workstation.

Fix the features are not compatible with the current configuration of your server

To resolve this issue, we will have to enable the Virtual Machine Processor Settings. The Virtual Machine must be turned off in order to perform this task. To do this, please follow the steps below.

Right-click on the VM and select settings as shown below. This will open up the Virtual Machne Settings window

Validation process errors

Alternatively

You can click on the Server on the VMware Workstation Pro dashboard. Now, click on Edit virtual machine settings.

Click on Processors, and ensure the “virtualize intel vt-x/ept or amd-v/rvi” button is checked. Click on Ok when done.

Screenshot-2021-07-07-at-17.06.31

Note: IOMMU (Intel VT-D) provides direct memory access (DMA) protection.

Power on your VM and select/install the role/feature (HyperV in my case) as shown below. Here is a similar error: Enable virtualization in Windows: How to fix VirtualBox Displaying only 32 bits Option.

Screenshot-2021-07-07-at-18.00.31

Kindly refer to this similar guide “Please enable the Virtual Machine Platform Windows Feature and ensure Virtualization is enabled in the BIOS: How to enable virtualization (VT-X) in VMWare workstation“.

I hope you found this blog post on VMware Workstation Pro helpful in resolving “Validation process found problems on the server to install features’. Please let me know in the comment session if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization Tags:VMware, VMware Workstation

Post navigation

Previous Post: Out-of-Band Security Update for PrintNightmare: Patch released for Windows Print Spooler Remote Code Execution Vulnerability
Next Post: Setup Hyper-V via the Server Manager or PowerShell or DISM

Related Posts

  • vSwitches
    vSwitches: How to delete Virtual Switches from Hyper-V Virtualization
  • Hyper V Virtual Switch
    How to Create Hyper-V Virtual Switch Network | Monitoring
  • loc
    Solve VMware workstation .lck error [Part 1] Virtualization
  • FailedRegistration
    DNS Bad key 9017: The Cluster Name registration failed of one or more associated DNS names Virtualization
  • screenshot 2020 04 06 at 04.12.00
    How to install and Configure Pleasant Reset Password Virtualization
  • Synology NFS Share
    Add Synology NFS Storage to Proxmox VE for VMs and Backups Storage

More Related Articles

vSwitches vSwitches: How to delete Virtual Switches from Hyper-V Virtualization
Hyper V Virtual Switch How to Create Hyper-V Virtual Switch Network | Monitoring
loc Solve VMware workstation .lck error [Part 1] Virtualization
FailedRegistration DNS Bad key 9017: The Cluster Name registration failed of one or more associated DNS names Virtualization
screenshot 2020 04 06 at 04.12.00 How to install and Configure Pleasant Reset Password Virtualization
Synology NFS Share Add Synology NFS Storage to Proxmox VE for VMs and Backups Storage

Comments (2) on “The validation process found problems on the server to which you want to install features, the features are not compatible with the current configuration of your server”

  1. Avatar photo Vanessa Maheshe says:
    21/11/2023 at 9:51 AM

    thank you dear

    Log in to Reply
    1. chris Christian says:
      21/11/2023 at 1:50 PM

      Many thanks, Vanessa!

      Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Slide1 1
    Create Multiple Users with Passwords in Ubuntu Linux Linux
  • integrate Icloud with Windows
    Synchronize Apple Calendar on Windows with Outlook [Part 2] Mac
  • Remote desktop connection over udp and tcp
    Remote Desktop Connection behavior over UDP and TCP Windows Server
  • windows powershell thumbnail
    Unable to uninstall AppX? How to uninstall builtin programs using PowerShell in Windows 10 Scripts
  • QueryBitLocker1
    Query Windows BitLocker status remotely Windows
  • Screenshot 2022 03 29 at 19.47.05
    CVE-2022-22948: Patch available to address vCenter Server information disclosure vulnerability  Security | Vulnerability Scans and Assessment
  • Slide2
    How to Clear Cache on Windows 10 Windows
  • posfix as an smtp server
    How to Install and Configure Postfix as a Send-Only SMTP Server Linux

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.