Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Solve VMware workstation .lck error [Part 1]

Posted on 29/10/202031/08/2026 Christian By Christian 1 Comment on Solve VMware workstation .lck error [Part 1]
  1. Home
  2. Virtualization
  3. Solve VMware workstation .lck error [Part 1]
VMware Workstation troubleshooting

One error you are bound to meet within your career as a Linux Administrator is a ”frozen” screen. It can be quite frustrating if you do not know what to do or where to look for the error logs. This Image below could be like this for a long time, not going further than this and not allowing any interaction on the machine. Our focus will be to discuss the steps to fix “the process cannot access the file because another process has locked a portion of the file. Resolve VMware workstation .lck error”. Please see How to install Windows Server 2022 on VMware Workstation, and How to Install Windows 10 on VMware Workstation.

Lock files are created when a virtual machine is powered on. Their purpose is to prevent multiple VMware processes from accessing the same virtual machine at the same time. The existence of a lock file indicates to VMware that the associated virtual machine is powered on.

Reason for VMware workstation .lck error

There are circumstances in which one or more lock files exist in a virtual machine’s directory. Even when the virtual machine is powered off. When this occurs, the only way that the virtual machine can be powered on is to manually remove the lock files.

.lck file error resolution

Some of the major causes could be Acute Shortage of Space and system resource exhaustion. Other times, the virtual machine creates lock files to prevent consistency problems on the virtual disk.

Please see How to disable automatic screen lock in Ubuntu Linux, and The security database on the server does not have a computer account for this workstation trust relation [Part 1].

Fix “The process cannot access the file because another process has locked a portion of the file”

One of the things you need to look for first is the iso image mirror. It is usually stored on the /Document/Virtual Machines folder if you are working with a Virtual Machine. It is always located in the same directory as the .vmdk files.

Virtual machine lock error fix

Open the folder locate the files and folder that have .lck extensions and delete them. Following the steps on ‘How to solve VMware Workstation .lck error.’

However, be sure these are not production processes locking the system down while they execute.

File directory displaying folders and files related to CentOS 64-bit virtual machine, including .vmdk, .vmx, and .lck files.

After deleting them, you will have to restart the machine. If it is hosted on a Virtual Machine. You may need to restart both the Virtual Machine and the host machine. After this, your system should start normally.

Furthermore, I hope you found this blog post on “How to solve VMware workstation .lck error” helpful. Please let me know in the comment section if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization Tags:VMware

Post navigation

Previous Post: Windows deployment cannot continue, the operating system is missing via MDT deployment
Next Post: Set PowerShell Execution Policy via Windows Settings

Related Posts

  • Burn ISO on MAC Proxmox installation
    Create a bootable USB on Mac: Proxmox VE Setup Virtualization
  • apply and install Veeam NFR Licence
    How to apply and install Veeam NFR License Backup
  • MAP virtual disk error
    Install Workstation Pro 17: Fix failed to initialise library for mounting and unmounting virtual disks Virtualization
  • VMware workstation networking issues
    Network cable Unplugged: Fix VMware “Warning – Multiple default gateways are intended to provide redundancy to a single network Virtualization
  • Windows Server 2019
    The virtual machine has terminated unexpectedly during startup with exit code 1 (1×0): Failed to open a session for the virtual machine Windows Server 2019 Virtualization
  • sandbox
    How to Configure Windows Sandbox Virtualization

More Related Articles

Burn ISO on MAC Proxmox installation Create a bootable USB on Mac: Proxmox VE Setup Virtualization
apply and install Veeam NFR Licence How to apply and install Veeam NFR License Backup
MAP virtual disk error Install Workstation Pro 17: Fix failed to initialise library for mounting and unmounting virtual disks Virtualization
VMware workstation networking issues Network cable Unplugged: Fix VMware “Warning – Multiple default gateways are intended to provide redundancy to a single network Virtualization
Windows Server 2019 The virtual machine has terminated unexpectedly during startup with exit code 1 (1×0): Failed to open a session for the virtual machine Windows Server 2019 Virtualization
sandbox How to Configure Windows Sandbox Virtualization

Comment (1) on “Solve VMware workstation .lck error [Part 1]”

  1. Avatar photo lucky says:
    09/09/2021 at 8:00 PM

    thanks a lot

    Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Microsoft Office 365 Family
    Download Microsoft Office 365 Family Invoice for tax reasons Microsoft Exchange/Office/365
  • image 92
    Install Let’s Encrypt Wildcard SSL Certificate in cPanel using Certify Configuration Management Tool
  • PowerShell Module Must be set to Remote Signed e1779570167985
    Veeam Backup and Replication: PowerShell must be Remote Signed Backup
  • WDS
    An error occurred while trying to start the Windows deployment services error 0x906 Windows Server
  • Distributed File System DFS
    All About Distributed File System Windows
  • screenshot 2020 03 13 at 20.24.17
    How to view installed packages in Cygwin on Windows Windows
  • Docker Installation on Ubuntu
    Docker Engine Installation on Ubuntu Network | Monitoring
  • cannot connect to the virtual machine try to connect again HyperV
    Could not connect to virtual machine try to connect again Hyper-V Virtualization

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.