Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

How to Reset Services Restore Mode (DSRM) Password

Posted on 04/07/202216/08/2026 Imoh Etuk By Imoh Etuk No Comments on How to Reset Services Restore Mode (DSRM) Password
  1. Home
  2. Windows Server
  3. How to Reset Services Restore Mode (DSRM) Password
Laps-in-Windows

Discover the significance of the Directory Services Restore Mode (DSRM) password, a critical but often overlooked element in Windows networks. This guide reveals the steps on How to Reset Services Restore Mode (DSRM) Password for a more secure DSRM environment Thereby ensuring a robust Active Directory structure. Please see Remote Desktop Services: How to Remove and Manage Terminal Server licenses from an RDP client with PowerShell.

The Services Restore Mode password enhance security and ensure a more robust DSRM environment for your organization. For Windows Server domain controllers, “Services Restore Mode” (DSRM) serves as a safe mode boot option.

An administrator can use DSRM to repair or recover an Active Directory database. During Active Directory installation, the wizard prompts for a DSRM password. When promoting a new Domain Controller, the DSRM password is set initially. This password grants database access for emergencies but not to the domain or services.

If you forget your DSRM password, you can change it with the command-line tool NTDSUtil. I’ve worked in a number of Active Directory environments where the DSRM password for the Domain Controllers is not known or safely stored for future use. Please see how to create and delete a custom AD DS partition with the NTDSUTIL.EXE Tool on Windows Server.

Why Setting Password to Secure DSRM?

Unlike workstations and servers, Domain Controllers do not have a local administrator account. This means you cannot log on to them locally. If Active Directory fails on a Domain Controller, you may be unable to log on with your domain credentials. This could prevent you from repairing Active Directory.

Directory Services Restore Mode (DSRM) is a boot option for Domain Controllers. It allows you to log in even if Active Directory has failed. You will use the local administrator account. To log in, enter .\administrator as the username.

The DSRM password is shown in the images below. This allows you to log in locally without having access to any domain.

Sign-in-using-DSRM

Attackers could use the DSRM account to stay persistent and gain access to the organization’s Active Directory.

Administrators typically set the DSRM password while promoting a Server to a Domain Controller as shown in the screenshot below and do not follow the recommendation to change its passwords on a regular basis.

Setting-DSRM-Password
Setting DSRM while promoting the DC

Knowing this, attackers will attempt to create a permanent backdoor in order to establish a future connection.

An attacker can change the password for the DSRM account by running the following command on each DC (or remotely against each DC by replacing "null" with the DC name).

Hackers-Reset-DSRM-Password-using-null
Resetting DSRM Password without Admin Permission

As shown above, when an attacker has obtained the DSRM password, he or she can use this account to log on to the DC as a local administrator over the network.

DsrmAdminLogonBehavior

The attacker can change the Windows registry using the local administrator password hash to log into the DC using Directory Services Restore Mode (DSRM) hashes without rebooting the server by confirming the “DsrmAdminLogonBehavior” registry key value under HKLM\System\CurrentControlSet\Control\Lsa and possibly create REG_DWORD values as shown below:

  • 0 – the default value – Can use the DSRM administrator account only if the DC starts in DSRM.
  • 1 – Use the DSRM administrator account to log on if the local AD DS service is stopped.
  • 2 – Always use the DSRM administrator account (This setting is not recommended because password policies do not apply to the DSRM administrator account).
Modified-the-Registry-1
Modifying the Registry Key

You can also learn about Group Policy Object: How to create a Password Policy via GPO, Volume Shadow Copies: How to configure VSS on Windows Server,

Enhancing Domain Controller Security with Regular Password Updates

To ensure a more secure and robust Active Directory environment for your Domain Controller, you need to constantly update the DSRM administrative complex password. Please keep in mind that DSRM is not the same as Safe Mode. If Active Directory fails to start in Safe Mode, you will be unable to log on.

Instead, use DSRM. As a Security administrator, you not only update the DSRM password regularly but also ensure the passwords are unique for every Domain Controller. Below, I’ll outline the steps to change the DSRM password:

Step 1 – Press Windows + Run to open the  Run dialog box, type ntdsutil, and then press the Enter Key.

RUn-ntdsutil-Run-command

Step 2 – At the Ntdsutil command prompt, type set dsrm password Still, at the DSRM command prompt, type one of the following lines "reset password on server null"

Reset-Password-on-Server-Null
Reset Password on Server

The null variable assumes that the DSRM password is being reset on the local computer. Therefore, you must set a unique password and regularly update it. Type the new password when prompted. Note that no characters appear while you type the password.

DSRM-Password-Set
DSRM Password Set
Note: To reset the password on another server, type reset password on server <servername>, where servername is the DNS name of the server being reset. When prompted, enter the new password. It's worth noting that no characters appear as you type the password.

When done resetting the password for DSRM, type q or quit at the DSRM command prompt and type q or quit also to exit Ntdsutil command prompt as well.

I hope you found this blog post on how to Reset Services Restore Mode (DSRM) Password helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Microsoft Windows, Windows Server 2016

Post navigation

Previous Post: How to Create a Password Policy with Group Policy Object
Next Post: Tamper Protection for Microsoft Defender on Windows 10 [Part 1]

Related Posts

  • EC2
    How to Add and Format a New Virtual Disk to an EC2 Instance AWS/Azure/OpenShift
  • images 3 4
    Fix an appropriate resource file could not be found for the file for BitLocker Management Windows Server
  • images
    How to fix you are not allowed to view this folder on SSRS: MBAM reports cannot be accessed because it could not load folder contents Windows Server
  • wsus logo e1653651564255
    How to configure Windows server update services Windows Server
  • image 41
    INACCESSIBLE BOOT DEVICE: Fix Your PC ran into a problem and needs to restart Windows
  • Shrink and Compact Virtual Hard Disks
    How to Shrink and Compact Virtual Hard Disks in Hyper-V Virtualization

More Related Articles

EC2 How to Add and Format a New Virtual Disk to an EC2 Instance AWS/Azure/OpenShift
images 3 4 Fix an appropriate resource file could not be found for the file for BitLocker Management Windows Server
images How to fix you are not allowed to view this folder on SSRS: MBAM reports cannot be accessed because it could not load folder contents Windows Server
wsus logo e1653651564255 How to configure Windows server update services Windows Server
image 41 INACCESSIBLE BOOT DEVICE: Fix Your PC ran into a problem and needs to restart Windows
Shrink and Compact Virtual Hard Disks How to Shrink and Compact Virtual Hard Disks in Hyper-V Virtualization

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Cannot Start Proctored Exam
    DbxSvc Process: How to Fix “Cannot Start Proctored Exam” Windows
  • rdp4
    How to change the default RDP port in Windows Network | Monitoring
  • banner
    How to Integrate Jira Software with GitHub Cloud JIRA|Confluence|Apps
  • Reverse Image Search
    How to Perform a Reverse Image Search on Your Browsers Network | Monitoring
  • git pull error
    Failed to pull image with the policy “always” error from the daemon Version Control System
  • Hibernation and faststartup
    Enable or Disable hibernation: How to fix the missing fast startup option on Windows Windows
  • How to Disable UAC with Group Policy and enable PIN in Windows Hello
    How to Disable UAC with Group Policy and enable PIN in Windows Hello Windows
  • vSwitches
    vSwitches: How to delete Virtual Switches from Hyper-V Virtualization

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.