Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

How to create Alarm rules in VMware vSphere

Posted on 11/05/202315/08/2026 Christian By Christian No Comments on How to create Alarm rules in VMware vSphere
  1. Home
  2. Virtualization
  3. How to create Alarm rules in VMware vSphere
Create-Alarm

VMware provides numerous tools to help administrators monitor their virtual environment to help identify potential and current issues. Alarms enable you to configure alerts and also specify the actions the system should take when they are triggered. In this guide, I will show you how to create Alarm rules in VMware vSphere. Here are some related guides: How to fix ESXI 6.7 ALARM: Seat disk exhaustion on 10, how to remove recent connections from the vSphere Client, How to upgrade VMware Tools in vSphere, how to Create a Snapshot on vSphere Web Client, and the Differences between vSphere and ESXi and vCenter.

vSphere includes a user-configurable events and alarms subsystem that tracks events happening throughout vSphere and stores the data in log files and the vCenter database. This enables you to specify the conditions under which alarms are triggered. Alarms can change state from mild warnings to more serious alerts as system conditions change and can trigger automated alarm actions. This functionality is useful when you want to be informed, or take immediate action, when certain events occur. Please see how to Perform Self-serve Password Reset using the “link for users who have forgotten their password”, and how to Add and Remove Multiple Virtual Desktops in Windows 10 | Multitasking.

Scenario: Monitor Guest Operating System Shutdown

To monitor your environment, you can create an alarm within the vSphere Client. You can create numerous alarm definitions in order to get notifications such as when exceeds a certain size etc.

Create Alarm rules in VMware vSphere

Go to Hosts, Clusters, and then to the Resource Pool depending on how your environment is structured. Locate the VM and right-click the VM and in the menu that opens, click Alarms as shown below.

Create-Alarm-VMware

Select New Alarm Definition

New-Alarm-Creation
The New Alarm Definition wizard opens.

Specify Alarm Name and Targets

Enter the alarm name. E.g., Guest OS shutdown Alarm, or if you wish to monitor snapshot sizes etc, enter a unique or identifiable name such as “vSphere snapshot monitor”.

Enter a description (optional). Select the Virtual Machine target type. Click Next at each step of the wizard to continue.

rule-creation

In the Alarm Rule Window, Please specify the argument of your choice such as “Guest OS Shutdown”. Also, do not forget to specify the severity. Alarms have the following severity levels:

  • Normal – green
  • Warning – yellow
  • Alert – red
Add-Alarm-Rule

When you are done specifying the Alarm Rules, click on next to continue.

Alarm Rule 1. Set the rule as follows:
IF
Guest OS Shutdown | You can add an argument
THEN
Trigger the alarm and Show as Warning
Send email notifications: ON
Subject: You can use the default subject
Email to: enter your email address
Populate-Alarm-rule-

Here are some more exciting guides: Why Data recovery is almost impossible from an overwritten Hard Drive, Understanding the different types of Proxy Servers, how to assign users with rights to perform a password reset in Active Directory, and how to fix MsSQL Connection timeout and timeout period expired.

Reset Rule 1

You can configure the reset rule similarly as you have configured the alarm rule. The reset rule is responsible for sending a notification message when the warning or critical conditions are no longer met for an inventory. Please populate the following window as it applies to you and click on Next to continue.

A better scenario for you would be to trigger an Alarm if VM is starting.
Reset-Rule-Creation

Review. Review your rule configuration. If everything is correct, hit the Create button.

Review-and-Create-Alarm-on-vSphere

I hope you found this blog post helpful on how to create Alarm rules in VMware vSphere. Please let me know in the comment section if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization Tags:Windows 10, Windows 11, Windows Server 2016

Post navigation

Previous Post: Setup VirtualHost with SSL on WAMP Server
Next Post: Manage MS365 Accounts with PowerShell

Related Posts

  • proxmox ve 6.1 released
    Installing Proxmox VE: Fix Volume Group Creation Error Virtualization
  • hyper v 1
    How to fix unable to create a new VM on HyperV Virtualization
  • 147913 228396 228395 rc
    Fix No bootable media found system halted: Unable to PXE boot Virtualization
  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
  • Azure Virtual Desktop
    How to deploy Azure Virtual Desktop in Azure Portal Virtualization
  • PXE Boot Stuck or No Boot Image was found Te bootloader did not find any operating system
    Fix PXE Boot Stuck or No Boot Image was found for HyperV VM Virtualization

More Related Articles

proxmox ve 6.1 released Installing Proxmox VE: Fix Volume Group Creation Error Virtualization
hyper v 1 How to fix unable to create a new VM on HyperV Virtualization
147913 228396 228395 rc Fix No bootable media found system halted: Unable to PXE boot Virtualization
OpenShift DR Hero e1784641900398 Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
Azure Virtual Desktop How to deploy Azure Virtual Desktop in Azure Portal Virtualization
PXE Boot Stuck or No Boot Image was found Te bootloader did not find any operating system Fix PXE Boot Stuck or No Boot Image was found for HyperV VM Virtualization

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • windows 10 creators
    Various methods on how to launch Windows Task Manager Windows
  • Windows server 2025 set up
    Install Windows Server 2025 via iDRAC Virtual Media or PXE Windows Server
  • Bulk operations in Azure AD
    Perform Bulk User Operations in Azure AD AWS/Azure/OpenShift
  • mdtxxxxx
    Failed to run the action install Operating System: Lifetouch deployment failed, Return Code = -2147467259 0x80004005 when installing Windows image via MDT Windows
  • fxcgbnm
    How to export and import Windows Start layout Windows
  • How to Check what files are taking up space
    WinDirStat: Check what files are taking up space on Windows Windows
  • install WSL on Windows
    How to install WSL on Windows Network | Monitoring
  • Feature image Error Code 0xC1900101 – 0x30018
    How to Fix Windows Update Error Code 0xC1900101 – 0x30018 Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.