Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

The security database on the server does not have a computer account for this workstation trust relation [Part 1]

Posted on 24/05/202005/09/2026 Christian By Christian No Comments on The security database on the server does not have a computer account for this workstation trust relation [Part 1]
  1. Home
  2. Windows Server
  3. The security database on the server does not have a computer account for this workstation trust relation [Part 1]
security database

Windows domains provide network administrators with ways to administer a great number of devices and control them from a central location. Domains are generally made up of computers on the same local network. You may want to see the following articles: How to synchronize your on-premises AD with Azure Active Directory using the Azure AD Connect tool, Configure TCP/IP Parameters: Post OS Installation and configuration of Windows Server 2019 properties, and how to fix the trust relationship between this workstation and the primary domain failed.

When a computer is joined to a domain, it doesn’t use its own local user accounts. User accounts and passwords are managed on the domain controller. When you log into a computer on that domain, the computer authenticates your user account name and password with the domain controller.

This means you can log in with the same username and password on any computer joined to the domain.

This error is a bit self-explanatory shown in the cover photo. This is because the computer object was deleted for so some other reasons in my lab environment.Please take a look at the [Part 2] guide “How to fix the issue “The Security Database on the Server does not have a Computer Account for this Workstation Trust Relationship” on Windows Server”.

Server Workstation Trust Relation Issue: Solution

Log on to the device with its local user account as shown below to solve this issue. For a similar error on the Windows trust relationship between this workstation and the primary domain failing, see the following link.

computer account

You will have to take the Server out of the domain and have it rejoined. Click on change settings

trust relation

In order to take the PC out of the Domain. Click on Work Group

server

Click on Ok. This will prompt the following information window below

security database

Click on Ok. This will prompt you to enter your username and password as shown below.

computer account

Click on Ok. Now you will get a welcome message saying, “Welcome to the DFF workgroup(Server Workstation Trust Relation Issue)”

security database

Click on Ok. Ignore the restart warning at the moment. Click on ok as shown below.

trust relation

Now we want to add the server back to the Domain. Local the System properties as shown below. Click on change

Windows System Properties window displaying computer name settings with 'DriveLock' as the computer description and 'DFF' as the workgroup, including a highlighted 'Change...' button for renaming the computer.

Enter you Domain name. Click on Ok as shown below

Screenshot of a computer settings window showing 'Computer Name/Domain Changes' with fields for 'Computer name', 'Full computer name', and options for 'Domain' and 'Workgroup', highlighting the text 'techdirect' and the 'OK' button.

This will prompt you to enter the domain administrators password as shown below

Windows Security prompt for Computer Name/Domain Changes, requesting username and password for domain access.

When the credentials are entered correctly, the window below will be prompted

Popup window indicating 'Computer Name/Domain Changes' with the message 'Welcome to the techdirect domain.' and an 'OK' button.

Thereafter you will be asked to restart in order for the settings to apply.

Windows system notification prompting the user to restart the computer to apply changes, with a reminder to save open files and close programs.

Click on Restart Now

Windows prompt notifying the user to restart the computer to apply changes, with options to 'Restart Now' or 'Restart Later'.

And that is all. Now you should be able to access your server again
– Enter your account in the sAM account or UPN as you wish

Screenshot 2020 05 24 at 23.05.55 1
Screenshot 2020 05 24 at 23.06.04

I hope you found this blog post on Server Workstation Trust Relation Issue helpful. Please let me know in the comment session if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Windows 10, Windows Server 2016

Post navigation

Previous Post: Differences between Capture image, Discover image, Install and Boot images
Next Post: How to uninstall the DriveLock Agent from your device

Related Posts

  • dns error
    Domain Name System Protocol: Client Registration Issue Windows Server
  • Hyper V VM creation
    How to Create a Windows Server VM on HyperV Windows Server
  • SSL for Localhost on WAMP
    How to configure SSL for WAMP server Windows Server
  • ADDS Already Contain a Computer Account
    How to fix ADDS already contain a computer account Windows Server
  • slide office 365 79
    Configure WSUS Email Notification for Office365 Windows Server
  • Distributed File System DFS
    All About Distributed File System Windows

More Related Articles

dns error Domain Name System Protocol: Client Registration Issue Windows Server
Hyper V VM creation How to Create a Windows Server VM on HyperV Windows Server
SSL for Localhost on WAMP How to configure SSL for WAMP server Windows Server
ADDS Already Contain a Computer Account How to fix ADDS already contain a computer account Windows Server
slide office 365 79 Configure WSUS Email Notification for Office365 Windows Server
Distributed File System DFS All About Distributed File System Windows

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Screenshot 2020 11 09 at 11.26.54
    The logon attempt failed for the remote desktop connection Windows Server
  • Screenshot 2020 06 15 at 21.08.38
    How to allow saved credentials for RDP connection Windows
  • blue screen error during windows 10 upgrade thumbnail
    Replace a blue screen error with a blank screen for system errors Windows
  • Slide2 2
    Oracle VirtualBox: Installing Windows 11 without TPM Support Virtualization
  • Wordpress banner
    Fix WordPress Error “The Link You Followed Has Expired” Web Server
  • PetitPotam
    PetitPotam attack on Active Directory Certificate Services: How to mitigate NTLM Relay PetitPotam attack on AD CS Security | Vulnerability Scans and Assessment
  • Delete reppo in VBR
    How to remove a Repository from Veeam Backup and Replication Backup
  • Install FileZilla Client
    FileZilla Client on Mac: How to Transfer Files to WordPress via SFTP Mac

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.