Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Domain Name System: How to create a DNS record

Posted on 15/07/202122/08/2026 Christian By Christian 3 Comments on Domain Name System: How to create a DNS record
  1. Home
  2. Windows Server
  3. Domain Name System: How to create a DNS record
DNS record creation

Active Directory Domain Services (AD DS) uses Domain Name System (DNS) name resolution services to make it possible for clients to locate domain controllers and for the domain controllers that host the directory service to communicate with each other. Please see how to add and verify a custom domain name to Azure Active Directory, Active Directory: How to Setup a Domain Controller, how to locate and edit the host file on macOS, and how to know when an IP or domain has been blacklisted.

AD DS enables easy integration of the Active Directory namespace into an existing DNS namespace. Features such as Active Directory-integrated DNS zones make it easier for you to deploy DNS by eliminating the need to set up secondary zones, and then configure zone transfers..

Kindly refer to the following related guides: How to setup a cache-only DNS server, how to locate and edit the hosts file on Windows, and how to install RSAT tools: DNS manager console missing from RSAT tools on Windows 10, how to setup SPF and TXT Records in AWS,

Launching DNS Manager for A Record Addition

To add an A record, kindly launch the DNS snap-in as shown below. From the Server Manager, click on Tools and then select Server Manager. Alternatively, you could start the DNS Manager from the Administrative Tools as well “(Click on Start, – Programs – Administrative Tools – DNS Manager).

DNS management

In the console tree, right-click the applicable forward lookup zone, and then click New Host (A or AAAA) as shown below. See this guide for the different types of DNS Records you can create.

Screenshot-2021-07-13-at-00.59.59

In the New Host window, enter the Name (e.g, TechDACluster), followed by the IP Address as shown below.

  • Ensure you check the “Create Associated PTR record” if you’ve configured the Reverse Arpa zone for automatic PTR record addition.
  • Click “Add Host” when you’ve finished.
Screenshot-2021-07-13-at-01.03.34

As shown below, we successfully created the record.

Screenshot-2021-07-13-at-01.04.05
Screenshot-2021-07-13-at-02.06.03

Find troubleshooting insights in these guides. The following error occurred when DNS was queried for the service location (SRV): Error code 0x0000232B RCODE_NAME_ERROR, and the following errors occurred attempting to join the domain: The specified domain either does not exist or could not be contacted.

I hope you found this blog post helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:DNS, DNSRecord, Microsoft Windows, Windows 10, Windows Server 2016

Post navigation

Previous Post: Quarantine state in Windows Failover Clusters: How to resolve quarantined Cluster Node on Hyper-V
Next Post: Failover Cluster Manager failed while managing one or more clusters, the error was unable to determine if the computer exists in the domain

Related Posts

  • dfefeq
    Error 740: Elevated permissions are required to run DISM Windows Server
  • update powershell in Windows
    Upgrade PowerShell Core Windows or Mac and Linux System Windows
  • dism failed errors windows thumbnail 1
    Error 0x800f0830: Discard the modified Image and start again, no operation was performed Windows Server
  • WSUS Analysis and Initial Assessment
    Preliminary Guide for WSUS Analysis and Initial Assessment Windows Server
  • Capture
    An account with the same name exists in Active Directory: Re-using the account was blocked by a security policy Security | Vulnerability Scans and Assessment
  • windows pe screenshot1 rcm1200x0
    Workaround and Permanent fix for this snap-in performed a non-valid operation and has been unloaded: To continue using this snap-in restart MMC or try loading the snap-in again Windows Server

More Related Articles

dfefeq Error 740: Elevated permissions are required to run DISM Windows Server
update powershell in Windows Upgrade PowerShell Core Windows or Mac and Linux System Windows
dism failed errors windows thumbnail 1 Error 0x800f0830: Discard the modified Image and start again, no operation was performed Windows Server
WSUS Analysis and Initial Assessment Preliminary Guide for WSUS Analysis and Initial Assessment Windows Server
Capture An account with the same name exists in Active Directory: Re-using the account was blocked by a security policy Security | Vulnerability Scans and Assessment
windows pe screenshot1 rcm1200x0 Workaround and Permanent fix for this snap-in performed a non-valid operation and has been unloaded: To continue using this snap-in restart MMC or try loading the snap-in again Windows Server

Comments (3) on “Domain Name System: How to create a DNS record”

  1. Avatar photo Eric says:
    22/03/2022 at 3:47 AM

    these steps are well known and all over the internet. However after searching for hrs I wasnt able to find the next natural step: that is pinging new host by name by client PCs in AD. After I registering my LINUX in AD it is pingable by name only on domain controller but not by any other PC in the zone (I can ping new host by IP though from any machine).
    Did you actually try to add a LINUX host and making sure is pingable by name from other PCs?

    Log in to Reply
    1. chris Christian says:
      22/03/2022 at 5:33 PM

      No, I haven’t had the need to test this. But in the future, we will be writing a guide on why join a Linux device to AD and how to join a Linux device to AD.

      Log in to Reply
      1. Avatar photo Eric says:
        23/03/2022 at 3:52 PM

        thank you Christian for the replay. Instr. for joining Linux to AD are out there too (like realm or sssd, etc) but I will definitely check your upcoming guide.

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • VM failed to Start on Hyper V e1781126442904
    Fix an error occurred while attempting to start selected VM on Hyper-V Virtualization
  • diagnose
    How to Diagnose a Windows Hardware Issue Windows
  • synology
    Synology Surveillance365: Cloud-Based Camera Management Without an On-Premises Surveillance Server Reviews
  • exchange 2016 1
    Remove Microsoft Exchange Server: Using ADSIEdit Tool Network | Monitoring
  • image 28
    How to monitor your website uptime and status using Uptime Configuration Management Tool
  • sonarlite
    How to Setup SonarLint in VS Code for Your App Project Configuration Management Tool
  • Featured image TeamsGif.
    How to fix Microsoft Teams GIFs or Images not working Windows
  • adc
    How to add a second Domain Controller Windows Server

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.