Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

How to create a Windows Server reference image using WDS

Posted on 07/06/202005/09/2026 Christian By Christian No Comments on How to create a Windows Server reference image using WDS
  1. Home
  2. Windows Server
  3. How to create a Windows Server reference image using WDS
Windows Server

Creating a reference image is important because that image serves as the foundation for the devices in your organization. This image will serve as the core operating system you need in your network environment. The image requires all the needed software for your Windows Servers to be installed. Please see How to Fix The Virtual Desktop is Not Sysprep Generalized, How to create a Windows Server reference image using WDS, and SysPrep was unable to validate your Windows Installation.

So before capturing the Windows Server image, ensure you update the applications and Windows with the latest updates. See this guide on how to create a Windows 10 reference image using MDT.

Windows Server capture with WDS is relatively straightforward. You need to have your WDS installed and also have the WDS configured. In order to demonstrate this, I made a clone of a Server in my lab environment.

Below are the steps needed to capture an image via WDS

Firstly, you will have to run Sysprep. This brings me to the point “What is Sysprep? See this guide for how to perform Sysprep and also why is Sysprep needed after cloning a VM.

Access the path below and execute the utility to Syspep your server.

c:\windows\system32\sysprep
reference image

Once the Sysprep has completed, the system will restart and boot it from Network. You must configure your system to boot from the network. Just press F12 to go to PXE.

Now select Capture Image to capture Windows 10 reference image of the Server.

Note: To complete this step, ensure you have created a captured image on Windows Deployment Services and have been uploaded to WDS as well.

WDS

This will ensure the capture image is loaded as shown below.

Windows Server
Screenshot 2020 06 07 at 00.13.22
create
Screenshot 2020 06 07 at 00.15.29

On the Welcome to Windows Deployment Services Image Capture Wizard page. Click Next

reference image

Now select the directory where you want to capture, type image name and image description then click Next.

Note: If your Volume is not Sysprepped, you cannot proceed.

If you have already sysprepped and you can not select the drive, this is because you had little delays, etc. You have to very careful and Sysprep the server (VM) again and ensure you press F12 immediately to PXE boot.

Windows Deployment Services Image Capture Wizard interface showing options to select volume to capture, enter image name, and image description, along with navigation buttons.

Select Name and Location or tick the checkbox of Upload image to a Windows Deployment Services server.

Note: You can optionally upload the image to WDS on the fly. This will require to connect and type user credentials.

In my case, I could connect to the server using the User Principle Name format (UPN). Select the Image Group name also, then click Next.

Note: This group (Windows Server) must also be created in your WDS under your install images.

Screenshot 2020 06 07 at 00.55.14
Screenshot 2020 06 07 at 00.55.14
Screenshot 2020 06 07 at 00.41.30 2
Screenshot 2020 06 07 at 00.41.30 2

Nevertheless, It will take forever to complete the process of capturing the Windows Server reference image

Screenshot 2020 06 07 at 02.46.16
Screenshot 2020 06 07 at 02.46.16
Screenshot 2020 06 07 at 02.47.13
Screenshot 2020 06 07 at 02.47.13

This Windows Image meta data

Windows Deployment Services Image Capture Wizard progress screen showing task progress with a green progress bar indicating that Windows image metadata is being captured.

Next, the Windows Server captured image will be sent and uploaded to the WDS server (remember, this option was checked above). Nonetheless, Sit back and relax as this process can take some time.

Windows Deployment Services Image Capture Wizard displaying upload progress, currently at 0% complete, with options to 'Back', 'Finish', or 'Cancel'.

At this moment, we can see from the Windows Event log that the ports needed to transfer this image to the WDS servers are open.

Screenshot of Windows Event Viewer displaying Windows Deployment Services with a list of events and diagnostics information.

When the capturing process completes, click Finish and restart your Windows Server reference PC. 

  • Configure and select the reference PC language, time, user, and password because Sysprep has stripped this.
  • Go to the Windows Deployment Server and check the result of the Windows Server capturing Image. However, The Windows Server captured image should be transferred successfully to WDS server

I hope you found this blog post on Windows Server reference image using WDS helpful. Furthermore, Please let me know in the comment session if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:WDS, WDSUTIL, Windows 10, Windows Deployment Services, Windows Server 2016

Post navigation

Previous Post: How to perform sysprep in Windows
Next Post: DriveLock Components: Important DriveLock components to master

Related Posts

  • Customizing Windows PE e1776163892496
    Steps to customize Windows PE boot images Windows
  • article 1280x720.192a2586 1 1
    No valid offer received: WDS PXE-E16 error when booting clients Windows Server
  • Slide2 1
    Create and Delete AD DS Partition with NTDSUTIL.EXE Windows Server
  • unnamed 1
    NSlookup Displays Error: UnKnown Default Server Windows Server
  • the remote procedure call failed
    Error 0xc1420117: The directory could not be completely unmounted Windows Server
  • fgh
    Configure log on as a batch job permissions on any server Windows Server

More Related Articles

Customizing Windows PE e1776163892496 Steps to customize Windows PE boot images Windows
article 1280x720.192a2586 1 1 No valid offer received: WDS PXE-E16 error when booting clients Windows Server
Slide2 1 Create and Delete AD DS Partition with NTDSUTIL.EXE Windows Server
unnamed 1 NSlookup Displays Error: UnKnown Default Server Windows Server
the remote procedure call failed Error 0xc1420117: The directory could not be completely unmounted Windows Server
fgh Configure log on as a batch job permissions on any server Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • image 11
    Setting Up your Amazon S3 Glacier and FastGlacier for Your Online Vault AWS/Azure/OpenShift
  • AzureCloudShell
    Provisioning Azure Resources using Azure Az PowerShell Cmdlet from Cloud Shell AWS/Azure/OpenShift
  • SCSI Controoler HyperV issue failed to start VM
    Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found Virtualization
  • Feature image Hiren's boot
    Recover your data after system failure with Hiren’s boot Backup
  • Screenshot 2022 03 29 at 19.47.05
    CVE-2022-22948: Patch available to address vCenter Server information disclosure vulnerability  Security | Vulnerability Scans and Assessment
  • Screenshot 2021 10 07 at 00.00.32
    How to fix this computer is a domain controller: The snap-in cannot be used on a domain controller Windows Server
  • untitled 5 1
    Migrate Veeam MSSQL Database to a new Microsoft SQL Server Backup
  • nextcloudfeature 1
    How To Install Nextcloud on a Linux system Backup

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.