Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

AADSTS50020: User from Identity Provider does not exist in Tenant

Posted on 19/11/202424/06/2026 Christian By Christian No Comments on AADSTS50020: User from Identity Provider does not exist in Tenant
  1. Home
  2. AWS/Azure/OpenShift
  3. AADSTS50020: User from Identity Provider does not exist in Tenant
AADSTS50020_ User from Identity Provider does not exist in Tenant

In this article, we shall discuss how to fix “AADSTS50020: User from Identity Provider does not exist in Tenant”. The error code AADSTS50020 gets returned if a user/guest user from an identity provider (IdP) can’t sign in to a resource tenant in Microsoft Entra ID. Microsoft has documented different use-cases which might be relevant to you. Please see “How to add and verify a custom domain name to Azure Active Directory“, and how to Move Azure Resources between Subscriptions.

As mentioned in the use-case above, none of these errors are applicable to me as I was using the default user account created for Entra ID <tenantname>.onmicrosoft.com. I also, tried using a user account associated with the custom domain as shown below. Yet, it did not work.

AADSTS50020 User account

Also, see Delete Azure Tenant: Remove Custom Domain from Entra ID, “Microsoft Azure Active Directory: How to setup Azure AD Tenant“, and “How to implement Interactive Authentication using MSAL dotNET“.

Root Issue for AADSTS50020: User from Identity Provider does not exist in Tenant

Cookies can affect authentication processes, including the error AADSTS50020: User from Identity Provider does not exist in Tenant. But might not be the cause for you as it are not the primary cause of this error.

Please see the link shared above from Microsoft for more information. Below are primary cause of the error (AADSTS50020)

  • A user is attempting to sign in to an Azure AD application or service but is not a member of the specified Azure AD tenant.
  • The application is configured for single-tenant use, but the user is from a different tenant (e.g., external users).
  • Misconfigured Identity Provider (IdP) settings or incorrect tenant configurations in the Azure AD application.

Resolution

Since cookies store session information and identity tokens during authentication, it can lead to Cross-Tenant Confusion.

If you have logged in to multiple Azure tenants or used multiple accounts in the same browser session, cookies might cause the browser to use an incorrect account or session, leading to the error due to cached session tokens.

To fix this, I will have to clear my browsing data as shown below.

clear cookies

Since I am on Chrome, I will select the time rang. I will also ensure the tab for cookies and other site data is selected.

delete cookies
Clear cookies and cache from the browser to remove stale session tokens and ensure a fresh authentication process

Initiate the sign-in process again. Then the error “AADSTS50020: User from Identity Provider does not exist in Tenant” will be gone.

Access Azure Portal

I hope you found this article useful on “AADSTS50020: User from Identity Provider does not exist in Tenant”. Please feel free to leave a comment below.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
AWS/Azure/OpenShift Tags:Azure, Azure Active Directory, Azure AD

Post navigation

Previous Post: Delete Azure Tenant: Remove Custom Domain from Entra ID
Next Post: How to Create a User and Custom Domain in Entra ID

Related Posts

  • maxresdefault 2 5
    Why am I unable to ping the Public IP Address of an EC2 instance AWS/Azure/OpenShift
  • IAM AWS
    Creating IAM Users, Adding MFA and Policies on AWS AWS/Azure/OpenShift
  • computefeature
    How to use Azure Compute Gallery AWS/Azure/OpenShift
  • M365 password reset
    How to reset Microsoft 365 User Password AWS/Azure/OpenShift
  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
  • Azure Backup For AKS
    How to protect Azure Kubernetes Service (AKS) with Azure Backup AWS/Azure/OpenShift

More Related Articles

maxresdefault 2 5 Why am I unable to ping the Public IP Address of an EC2 instance AWS/Azure/OpenShift
IAM AWS Creating IAM Users, Adding MFA and Policies on AWS AWS/Azure/OpenShift
computefeature How to use Azure Compute Gallery AWS/Azure/OpenShift
M365 password reset How to reset Microsoft 365 User Password AWS/Azure/OpenShift
OpenShift DR Hero e1784641900398 Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
Azure Backup For AKS How to protect Azure Kubernetes Service (AKS) with Azure Backup AWS/Azure/OpenShift

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • How to Install Winget on Windows Server
    How to Install Winget on Windows Server Windows Server
  • SSL on WAMPServer
    Setup VirtualHost with SSL on WAMP Server Linux
  • SizeTrend
    SizeTrend: A Fast Windows Disk Space Analyzer for Storage Analysis Windows
  • react 1
    How to deploy a React Application to AWS S3 AWS/Azure/OpenShift
  • WindowsCoreSecurity
    How to enable Smart App Control on Windows 11 Security | Vulnerability Scans and Assessment
  • Amazon
    Import Virtual Machines to AWS as AMI AWS/Azure/OpenShift
  • XCP ng installation and VM creation
    A-Z of XCP-ng and Xen Orchestra setup and VM Creation Virtualization
  • ansible vault
    Fix AttributeError ‘ShellModule’ Object Has No Attribute ‘ECHO’ Configuration Management Tool

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.