Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Fix an appropriate resource file could not be found for LAPS

Posted on 03/05/202315/08/2026 Christian By Christian 2 Comments on Fix an appropriate resource file could not be found for LAPS
  1. Home
  2. Windows
  3. Fix an appropriate resource file could not be found for LAPS
Missing-ADML-File

In this article, I will walk you through how to fix an appropriate resource file could not be found for LAPS. Windows uses a Central Store to store Administrative Templates files. To take advantage of the benefits of .admx files. You must create a Central Store in the sysvol folder on a Windows domain controller. Please see how to create the central store for Group Policy Administrative Templates. How to fix LAPS password not showing up in GUI, and how to Fix error “You must specify user account name when adding a DC to an existing Forest“.

The Central Store is a file location that is checked by the Group Policy tools by default. The Group Policy tools use all .admx files that are in the Central Store.

Administrative Templates files are divided into .admx files and language-specific .adml files for use by Group Policy administrators. The changes that are implemented in these files let administrators configure the same set of policies by using two languages. Administrators can configure policies by using the language-specific .adml files and the language-neutral .admx files.

Here are some exciting articles: What are the differences between an ADM and ADMX file? How to fix Unable to find File Explorer in the Group Policy Editor when resolving the security tab missing under properties,

Reason for the error “an appropriate resource file could not be found for LAPS”

The error below is incorrect because it is referring to the .admx file as missing. While being present at the specified location. The error is prompted because the ADMX Policy file is present, but not the ADML file. Both files must exist for the policy to appear in the local group policy editor.

ADMX-An-appropriate-resource-file-could-not-be-found-for

Note: To reiterate further, to generate reports or edit the GPO. The .admx file MUST be loaded as well as the appropriate .adml language file. Depending on the native language user requesting the edit/reporting operation the .adml file is searched for in the appropriate language folder (en for en, de for de, and so on).

By default since the April 11 update, Windows installs LAPS.admx under %systemroot%\PolicyDefinitions. You are advised to copy the ADML file into the Central store in order to utilize it. Most times, the corresponding LAP.adml file is forgotten as it has not been expressly mentioned. It happens!!!

Please see how to fix LAPS password not showing up in GUI. How to Configure Windows LAPS Management with Microsoft Intune, and how to fix an appropriate resource file could not be found for the file: The system can not find the file specified for MDOP.

Resolution – To fix this issue ‘An appropriate resource file could not be found for LAPS”

Please copy the corresponding ADML file for Local Admin Password Solution from C:\Windows\PolicyDefinitions\en-US to the central Store to the

 \\TECHDARCHIVEDC\sysvol\Techdirectarchive.local\Policies\PolicyDefinitions\

For instance, if the querying user wants English and the GPO central store only has the German .adml files installed such an error would also be prompted.

LAPS.adml_

As you can see, the LAPS.adml file has been copied to the central store: \\TECHDARCHIVEDC\sysvol\Techdirectarchive.local\Policies\PolicyDefinitions\

Central store LAPS.adml file

When this is done, the error will be eliminated. Please see How to configure Windows LAPS, and how to fix the Error: Administrative templates retrieved from the local computer do not show up.

Group Policy Editor

I hope you found this blog post helpful on how to fix an appropriate resource file could not be found for LAPS. Please let me know in the comment section if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows, Windows Server Tags:Microsoft Windows, Windows 10, Windows 11, Windows Server 2016

Post navigation

Previous Post: LAPS password not showing up in GUI
Next Post: Upgrade Windows Server 2019 to 2022 via iDRAC

Related Posts

  • EC2
    How to Add and Format a New Virtual Disk to an EC2 Instance AWS/Azure/OpenShift
  • fix 0x00400d error
    Fix the request to add or remove features failed 0x00400d Windows Server
  • Clone a Virtual Machine via Export and Import
    Clone a VM via Export and Import: Copy Virtual Hard Disk on Hyper-V Virtualization
  • Smartscreen defender blocking application
    Unable to run downloaded Programs due to Defender SmartScreen Windows
  • PIN9 1
    How to increase Windows PIN complexity Windows
  • A connection to the deployment share could not be made Errors in MDT e1781960443644
    PCI Driver Error: Connection to Deployment Share could not be made Windows

More Related Articles

EC2 How to Add and Format a New Virtual Disk to an EC2 Instance AWS/Azure/OpenShift
fix 0x00400d error Fix the request to add or remove features failed 0x00400d Windows Server
Clone a Virtual Machine via Export and Import Clone a VM via Export and Import: Copy Virtual Hard Disk on Hyper-V Virtualization
Smartscreen defender blocking application Unable to run downloaded Programs due to Defender SmartScreen Windows
PIN9 1 How to increase Windows PIN complexity Windows
A connection to the deployment share could not be made Errors in MDT e1781960443644 PCI Driver Error: Connection to Deployment Share could not be made Windows

Comments (2) on “Fix an appropriate resource file could not be found for LAPS”

  1. Avatar photo chris says:
    14/06/2023 at 9:30 PM

    Helpful post!

    Log in to Reply
    1. chris Christian says:
      16/06/2023 at 10:56 PM

      Thank you very much, Chris!

      Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • ClamAV
    How to install and manage ClamAV and ClamTK on Ubuntu Linux Anti-Virus Solution
  • Remove Nextcloud Desktop Client
    How to correctly uninstall Nextcloud from Mac Mac
  • Featured image 6
    How to remove OneDrive from Windows Microsoft Exchange/Office/365
  • azure logo 1
    How to use the built-in Azure Active Directory Connect tool AWS/Azure/OpenShift
  • Create Windows Defender Firewall Rule
    Fix Windows defender blocked incoming connection on Windows Network | Monitoring
  • Windows Server 2016 1
    All About Windows Server 2016 Windows Server
  • SQL Server Management Studio 1
    How to manually check and update SQL Server Management Studio Oracle/MSSQL/MySQL
  • git pull error
    Failed to pull image with the policy “always” error from the daemon Version Control System

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.