Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

The following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection

Posted on 29/03/202315/08/2026 Christian By Christian No Comments on The following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection
  1. Home
  2. Windows Server
  3. The following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection
RDS-Architecture-

A Remote Desktop Service (RDS) deployment pool is a collection of RD Session Host servers that work together to provide remote desktop and application services to users. The RD Session Host servers in the pool can be load-balanced to optimize resource usage and improve performance. In this guide, we shall be discussing the steps to fix “The following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection”. Please see how to Remove a Remote Desktop Service Collection, and Remote Desktop Services Setup on Windows Server.

When users connect to the deployment pool, they are redirected to an available RD Session Host server in the pool depending on the use case for deployment. The RD Connection Broker service manages the connection redirection and load balancing.

RDS Deployment Pool

The goal of this task is to add a VM to an RDS session host to the deployment pool and create a collection. The following steps below will help you in actualizing this task. This specific scenario will help achieve load balancing. Please refer to these interesting guides: Determine the Remote Desktop Client Version,  How to enable or disable WMI Traffic Using Firewall UI, and Allow RDP access for non-administrators: Add User to Remote Desktop Users Group in Active Directory.

To create an RDS deployment pool, you will need to have a server running Windows Server with the Remote Desktop Services role installed. You will also need to have one or more RD Session Host servers available to include in the pool.

Why was the error “following servers in this deployment are not part of the deployment Pool, the servers must be added to the Server Pool” Prompted

Note: This is not an error, it prompts up when you have a heterogenous environment and want to create a new session host on the server. This ensures a lot of Remote Desktop Session Hosts are able to use a single Remote Desktop Licensing Server.

Kindly refer to these related guides: How to install RDS via Quick Start Deployment: Install, Publish, Update and Uninstall Remote Desktop Web Client, and How to fix the issue “The remote session was disconnected because there are no Remote Desktop License Servers available to provide a license”.

server-not-in-the-list-of-deploymet-1

Fix the following servers in this deployment are not part of the deployment Pool

This step involves adding the “RDS Session Host Servers” to the Deployment Pool. You will need to launch the RDSWebAccess Server and add the list of server not available in the pool to it. In this way, you will RESOLVE the following error “The following servers in this deployment are not part of the deployment Pool, the servers must be added to the Server Pool”.

When the above error is resolved. You can now start off by creating your Remote Desktop Session host and Collection share afterwards. You may be interested in this “Event ID 5059: Application pool has been disabled or Changing identity user for IIS Application Pool“

Add a server to RDS Server Pool

Launch the server manager if not already opened. Then click on the Manage menu, then select Add Servers. Alternatively, you can right-click on “All Servers” and select Add Servers.

Add-RDS-Servers

On the Active Directory tab, select servers that are in the current domain. Press Ctrl while selecting to select multiple servers.

Click the right-arrow button to move selected servers to the Selected list. Select the servers that you want to add. When you are finished adding servers, click OK.

Here are some related guides: Install and License Devolutions Remote Desktop Manager, RDP Users are unable to change Passwords, and How to Remove and Manage RDS Licenses.

Create an RDS Session Host

Connect to the Remote Desktop Web Access Server. Launch the Server Manager and click on Remote Desktop Services. It will connect to the RDS broker

RDS-deployment

To install the Remote Desktop Session Host role on the VM. Please see this guide. “How to install RDS via Quick Start Deployment: Install, Publish, Update and Uninstall Remote Desktop Web Client.

You just have to click ok Add RD Session Host Sers as shown in the image above. Follow through the rest steps.

You will be prompted to select the server to which you want to add the RD Session Host Server to. Follow through the prompts as it is very easy to complete. Take a look at these. Publish Remote Desktop Web Client: Install HTML 5 Web Client for Microsoft RDS Server. And also this Laps in Windows: How to Reset Directory Services Restore Mode (DSRM) Password.

Create Remote Desktop Services Collection

Note: A session collection holds the apps and desktops you want to make available to users. After you create the collection, publish it so users can access it.

Once the RDS Session Host server is added to the deployment and you have created a collection. Users can connect to the collection and access the remote desktops hosted on the new server that you added.

Users will be redirected to the RD Session Host server that has the lowest connection load in the collection. Which helps balance the workload across the RDS deployment. (That is if this is the use case for your environment). Please see How to add and remove RDS Collection

On the Setup RDS deployment, click on Create Collection. Once the collection is created, you can configure the session settings and other options.

RDS-deployment

I hope you found this blog post helpful on the following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Microsoft Windows, rds, RDS CALs, Remote Desktop Services, Windows 10, Windows 11, Windows Server 2016

Post navigation

Previous Post: Change Visual Studio Code UI language
Next Post: How to Migrate from TrueCrypt to BitLocker

Related Posts

  • hero activedirectory
    How to find disabled Active Directory User accounts Windows Server
  • image 1
    Install and License Devolutions Remote Desktop Manager on Mac Mac
  • Microsoft Defender
    Attack Surface Reduction Configuration with Microsoft Defender Scripts
  • add or remove features on the specified server failed
    Error 0x80073701: The request to add or remove features on the specified server failed Windows Server
  • microsoft logo rgb wht
    All about Group Policies: Group Policy GPUpdate Commands Windows Server
  • dfg
    DISM failed with error 0x800f081f: Source file could not be found Windows Server

More Related Articles

hero activedirectory How to find disabled Active Directory User accounts Windows Server
image 1 Install and License Devolutions Remote Desktop Manager on Mac Mac
Microsoft Defender Attack Surface Reduction Configuration with Microsoft Defender Scripts
add or remove features on the specified server failed Error 0x80073701: The request to add or remove features on the specified server failed Windows Server
microsoft logo rgb wht All about Group Policies: Group Policy GPUpdate Commands Windows Server
dfg DISM failed with error 0x800f081f: Source file could not be found Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Reload Tabs
    How to Reload all Microsoft Edge Browser Tabs Network | Monitoring
  • bluetooth headphones to mac 1200x628 1
    How to remove a Bluetooth device and connect a new Bluetooth device to Macbook Mac
  • Cross Domain Folders Access
    Cross Domain Folders Access: Reference account is Locked out Windows
  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
  • exchange 2016 1
    Workaround for a zero-day vulnerability on Microsoft Exchange Server Network | Monitoring
  • RDP Certificate Issues
    Connecting to the RDP host: Fix the Certificate could not be verified back to the root certificate Mac
  • PowerShell logo
    PowerShell: How to update PowerShellGet and Package Management Windows Server
  • Feature image registry editing
    How to Disable and Enable Registry Access on Windows 11 Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.