Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Failed to create a scheduled task: Cannot perform the operation because the runspace pool is not in the open state

Posted on 26/03/202016/09/2026 Christian By Christian No Comments on Failed to create a scheduled task: Cannot perform the operation because the runspace pool is not in the open state
  1. Home
  2. Windows Server
  3. Failed to create a scheduled task: Cannot perform the operation because the runspace pool is not in the open state
Logo of Windows Admin Center, featuring a server icon, toolbox, and various management tool icons on a blue background.

Windows Admin Center is a locally deployed, browser-based app for managing Windows servers, clusters, hyper-converged infrastructure, as well as Windows 10 PCs. In this guide, you will learn how to fix Failed to create a scheduled task: Cannot perform the operation because the runspace pool is not in the open state. Please see how to install Winglet and how to install applications with Winglet CLI. 

Windows Admin Center is a free product and is ready to use in production. When prompted with an error when trying to access WAC from other browsers saying the site is not secure.

See the following links for “How to setup Windows Admin Center, “How to install Chocolatey” and “How to install, upgrade and uninstall software with Chocolatey“.

Reason for the error “Cannot perform the operation because the runspace pool is not in the open state”

This problem occurs because there is no firewall rule that will allow Windows Admin Center access on the remote server.

Screenshot of Windows Admin Center displaying error notification for failed scheduled task creation with details of the error message.

To fix this issue, temporarily turn off the firewall on your device.

Note: This act is very UNSAFE
Windows Security interface displaying 'Firewall & network protection' settings with alerts indicating that Windows Defender Firewall is using potentially unsafe settings and that firewalls are turned off for both 'Domain network' and 'Private network'.

Then try to create your scheduled task. When the scheduled task is created successfully, then you have two methods to set up the firewall.

Please see “Failed to create a scheduled task: There is no disconnected command associated with the runspace“. Also, see the fix for “The following servers in this deployment are not part of the deployment Pool: Create an RDS Session Host and Collection“.

Method 1 to fix the Runspace Pool Issue

Create an Inbound Firewall rule via PowerShell.

New-NetFirewallRule -DisplayName „SmeInbounOpenException“ -Description „Windows Admin Center inbound port exception“ -Localport 6516 -Protocol TCP

Ensure to run PowerShell with Admin privilege, else it will FAIL 🙂

Screenshot of Windows PowerShell showing a command to create a new firewall rule named 'SmeInboundOpenException' for TCP protocol on port 6516, along with details of the rule configuration.

Here is the fix for “Application pool has been disabled or Changing identity user for IIS Application Pool (Event ID 5059)“, and the “Fix Error 183: The specified image is currently being serviced by another DISM operation“.

Method 2 to fix

You can also create this rule via the Windows Firewall (Windows Defender Firewall and Advanced Security. The firewall windows can be accessed via the following path

  • Control Panel
  • System and Security
  • Windows Defender Firewall
Windows Defender Firewall settings page showing options to update and configure firewall protection on a Windows PC.

This will open the Windows Firewall “Advanced Settings and Advanced Security” as shown below. In this method, you have got two options

You can choose to exclude WAC from the firewall or create a firewall rule with for the TCP/IP

Screenshot of Windows Defender Firewall with Advanced Security showing the New Inbound Rule Wizard. The 'Rule Type' options for 'Program' and 'Port' are highlighted.

I will opt to go with the option to exclude the program option and select the the

%ProgramFiles%\Windows Admin Center\sme.exe
Screenshot of the New Inbound Rule Wizard in Windows, showing options for selecting a program path and executable name.

Click to allow connections to the program as shown below

Screenshot of the 'New Inbound Rule Wizard' in a network security configuration, highlighting the option 'Allow the connection' with a description of its implications, alongside options to allow secure connections or block connections.

Select the profile it should apply to. Since this is a test environment. I will select all the profiles as shown below.

Screenshot of the 'New Inbound Rule Wizard' in a firewall application, showing the 'Profile' step with options for Domain, Private, and Public network locations selected.

Enter the firewall name and description of the rule and click on Finish

Screenshot of the 'New Inbound Rule Wizard' in a Windows application, showing a form to specify the rule name and an optional description field.

Either of the options you chose, you will and the same end result.

I hope you found this blog post helpful on how to fix Failed to create a scheduled task: Cannot perform the operation because the runspace pool is not in the open state. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Microsoft Windows, WAC, Windows 10, Windows Server 2016

Post navigation

Previous Post: Failed to create a scheduled task: There is no disconnected command associated with the runspace
Next Post: How to create a scheduled task with Windows Admin Center

Related Posts

  • Cloud Cost
    How to Control Cloud Cost Using Azure VM AWS/Azure/OpenShift
  • upgrade 2
    How to upgrade Windows Server Evaluation to Full Version Windows Server
  • Add a second domain to your domain
    How to add a new Domain Controller to an Existing Domain Windows Server
  • AGMP replacement e1778595633716
    AGMP extended support ends April 2026: Find alternative solution Windows Server
  • maxresdefault
    Error 0x8007232B: Can’t activate Windows on this device as we can’t connect to your organization’s activation server Windows
  • HyperV 2
    Fix no disks suitable for the cluster were found Windows Server

More Related Articles

Cloud Cost How to Control Cloud Cost Using Azure VM AWS/Azure/OpenShift
upgrade 2 How to upgrade Windows Server Evaluation to Full Version Windows Server
Add a second domain to your domain How to add a new Domain Controller to an Existing Domain Windows Server
AGMP replacement e1778595633716 AGMP extended support ends April 2026: Find alternative solution Windows Server
maxresdefault Error 0x8007232B: Can’t activate Windows on this device as we can’t connect to your organization’s activation server Windows
HyperV 2 Fix no disks suitable for the cluster were found Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Reset folder view settings on File Explorer for Windows 11 and 10
    Reset folder view settings on File Explorer for Windows 11 and 10 Windows
  • Storage Explorer
    How to Install Azure Storage Explorer on Windows AWS/Azure/OpenShift
  • Featured image
    Domain Naming System: Enabling DNS over TLS in Windows 11 Network | Monitoring
  • kubernetes
    Create and monitor Apps using the Azure Kubernetes Service manifest AWS/Azure/OpenShift
  • remote desktop connection tabs rdp tabs
    Guide to Remote Desktop Connection Properties for Secure Access Windows
  • veeamONE integration with VBR
    Install Veeam ONE and Add VBR: Fix failed to connect to VBR Backup
  • Manage Log Files via Logrotate
    How To Use Logrotate For Managing Log Files In Ubuntu Linux Linux
  • offloadanapp
    How to Offload Individual Apps on iPhone Mac

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.