Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Warning useradd: the home directory already exists. Not copying any file from skel director into it

Posted on 07/04/202015/09/2026 Christian By Christian 1 Comment on Warning useradd: the home directory already exists. Not copying any file from skel director into it
  1. Home
  2. Linux
  3. Warning useradd: the home directory already exists. Not copying any file from skel director into it
Warning useradd: the home directory already exists. Not copying any file from skel director into it

In Linux, the useradd is a command in Linux that is used to add user accounts to your system. The ‘useradd‘ command is a low-level utility that is used for adding/creating user accounts in Linux and other Unix-like operating systems. The ‘adduser‘ is much similar to the useradd command because it is just a symbolic link to it. You can find other guides here :How to locate directory file context and restore it with SELinux, How to create a static pod in Kubernetes. And Delivering System Utilization Report on a Linux based OS.

Only root or users with sudo privileges can use the useradd command to create new user accounts. When invoked, useradd create a new user account according to the options specified on the command line and the default values set in the /etc/default/useradd file.

I previously had a user created in my centOS environment. This user was later deleted and I tried creating a new user with the same name, then this error was prompted. See the image below for more information.

How to fix Warning useradd: home directory already exists

This “Warning useradd: home directory already exists” is actually not an error but just a warning and what this means is.

Note: Windows does not work like this 🙂 when you delete a user, the user, and the SID is gone unless the user account is recovered.

Terminal command output displaying user management commands, including 'userdel', 'useradd', and 'id'. Warning messages about existing home directory and mailbox creation.

But in Linux, the home directory is not immediately deleted. All files etc. will still be able for a while. When the system finally deletes the user, the account can be created again.

Terminal window showing command line operations: checking groups for user 'john' resulting in 'no such user', followed by command to add user 'john'.

Note: In windows, when a user is deleted, and a new user is created, a new SID is assigned. This is also the case in Linux as gid and groups id are now different for john as shown below.

Terminal window displaying the command 'id john' and its output showing user ID, group ID, and group membership for user 'john'.

I hope you found this blog post on Fixing Warning useradd: home directory already exists helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Linux Tags:users

Post navigation

Previous Post: Enable or disable Linux System’s Clock Sync with NTP Server
Next Post: Failed to create a new scheduled task name RemoteException: Cannot create the file when that file already exists

Related Posts

  • ssh
    How to disable RC4 Cipher Algorithms support in SSH Server Linux
  • APACHECASS FEATURE
    How to Install and Configure Apache Cassandra on Linux Server Linux
  • featuredpkg
    How to solve /var/lib/dpkg/lock Error in Ubuntu Linux Linux
  • dns
    How to setup a cache-only DNS server Linux
  • Locate Find and Grep Required 1
    Locate, Find and Grep: Search for files and patterns in Linux or Unix-like OS Linux
  • Manage Log Files via Logrotate
    How To Use Logrotate For Managing Log Files In Ubuntu Linux Linux

More Related Articles

ssh How to disable RC4 Cipher Algorithms support in SSH Server Linux
APACHECASS FEATURE How to Install and Configure Apache Cassandra on Linux Server Linux
featuredpkg How to solve /var/lib/dpkg/lock Error in Ubuntu Linux Linux
dns How to setup a cache-only DNS server Linux
Locate Find and Grep Required 1 Locate, Find and Grep: Search for files and patterns in Linux or Unix-like OS Linux
Manage Log Files via Logrotate How To Use Logrotate For Managing Log Files In Ubuntu Linux Linux

Comment (1) on “Warning useradd: the home directory already exists. Not copying any file from skel director into it”

  1. Avatar photo useraa says:
    24/10/2021 at 8:17 PM

    so its not affects anything ????

    Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Migrate from Universal Analytics to GA4 property
    Configure and Migrate from Universal Analytics to GA4 property Automation
  • VM failed to Start on Hyper V e1781126442904
    Fix an error occurred while attempting to start selected VM on Hyper-V Virtualization
  • Fixed Sysprep Generalize Copy
    How to Grant Local Admin Permissions to a Group [Part 1] Network | Monitoring
  • Credential Sync acrosss devices
    How to sync your passwords across iOS and Mac devices Mac
  • azurv2 1
    How to scale up and scale out on Azure AWS/Azure/OpenShift
  • images copy
    HA-Proxy Configuration File: Copy Between Nodes on Proxmox VE Virtualization
  • Prevent Standard Users from Changing BitLocker Password
    How to Prevent Standard Users from Changing BitLocker Password Windows
  • Featured image Teams Whiteboard
    How to use Whiteboard in Microsoft Teams meetings Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.