Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Fix SSO sign-in and non-routable domain issues

Posted on 22/07/202003/09/2026 Christian By Christian 2 Comments on Fix SSO sign-in and non-routable domain issues
  1. Home
  2. AWS/Azure/OpenShift
  3. Fix SSO sign-in and non-routable domain issues
azure-1

Single sign-on (SSO) is an identification method that enables users to log in to multiple applications and websites with one set of credentials. SSO streamlines the authentication process for users. After configuring Pass-Through Authentication (PTA) as discussed in the hyperlink, you may run into several user sign-in issues. In this guide, you will learn how to fix SSO sign-in and non-routable domain issues leading to invalid usernames and passwords. See how to Setup a Domain Controller as Recommended by Microsoft.

Note: Azure Active Directory (Azure AD) is being renamed to Microsoft Entra ID as part of our commitment to simplify secure access experiences for everyone. So, in this article, ensure to note the difference as this guide was created before it was renamed.

Please see how to fix the “Error: The processing of Group Policy failed because of lack of network connectivity to a DC. This may be a transient condition. A success message would be generated once the machine gets connected“, and how to Reset a Snom Phone.

Why was the error “SSO sign-in and non-routable domain issues” prompted?

You will not be able to sign in to Microsoft Office 365, Microsoft Azure, Microsoft Intune, etc. The sign-in error message is as follows “Invalid username and password – Your account or password is incorrect if you cannot remember your account reset it now“.

This could be a result of many other reasons: This can happen when Azure AD is unable to receive the Kerberos ticket from your on-premise user account or when a user’s on-premises UserPrincipalName (UPN) is different than the user’s cloud UPN.

Fix”sign-in, non-routable domains, invalid usernames, and passwords for SSO issues”?

To fix this issue, you need to use GPO to push some Azure URLs to your users’ internet zone settings. Here is a guide on how to synchronize your on-premises AD with Azure Active Directory using the Azure AD Connect tool, and how to use the built-in AAD Connect troubleshooting tool.

Note: Microsoft recommends not using a non-routable domain name suffix such as the dotlocal. The .local suffix isn’t routable and can cause issues with DNS resolution. With this fix, we can mitigate this issue.

For other similar causes that may apply to you, see the following possible fix for the issues below, they did not apply to me. Your subscription has expired.

– Your user account is not enabled.
– You’re locked out of your user account.
– You tried to sign in with the wrong username and password.
– The password you tried to sign in with is temporary and expired. (This might happen if your user account is new or your password was recently reset.)
– Your password has expired.
– You’re blocked from signing in.
– If you’re a federated user, single sign-on is not working.

Microsoft sign-in page prompting for password with an error message indicating incorrect account or password.

Note: Even when you try to reset the account, it will never be possible and the following error will be prompted.

Let’s simulate the issue with the environment to ensure that the Pass-through Authentication agent is working correctly before proceeding to fix the issue.

1: Import the PowerShell module on the agent machine

Import-Module Adsync

2: Run the following command from PowerShell as shown below

Invoke-PassthroughAuthOnPremLogonTroubleshooter
A Windows dialog box prompting for user credentials, displaying fields for 'User name' and 'Password', with an 'OK' button at the bottom.

Upon entering your credentials, the login will fail as shown below displaying the error code and failure reason.

Screenshot of a PowerShell terminal displaying an error message indicating a logon failure with error code 1326, stating 'The user name or password is incorrect.'

Since we are getting the same error “username and password is incorrect”, this means that the Pass-through Authentication agent is working correctly and the issue may be that the on-premises UPN is non-routable.

Azure Active Directory Pass-through authentication settings showing an active authentication agent and associated information.

Create GPO to push Azure URLs to your users’ Internet Zone Settings

As you can see we are using a different UPN for on-premise and this is different from the cloud UPN. To fix this issue, you need to use GPO to push some Azure URLs to your users’ internet zone settings and to ensure AAD is able to process the Kerberos ticket.

This step ensures that the domain-joined computer automatically sends a Kerberos ticket to Azure AD when it’s connected to the corporate network.

Since this is a Domain controller, we will have to access the Group Policy Object in the following way below.
Screenshot of the Server Manager Dashboard in Windows Server, displaying tools and options including 'Group Policy Management' highlighted.

Upon clicking on the Group Policy Management as shown above this will open the Group Policy Management Console

Screenshot of Group Policy Management console showing the Default Domain Policy settings for the domain 'techdirect.local'. The left panel displays domains and organizational units, while the right panel shows links, security filtering, and WMI filtering associated with the Default Domain Policy.

Now, I want to create a new GPO that will be linked to our domain. So when our user’s log on to the network with a PC. They will be able to perform SSO.

Screenshot of Group Policy Management in Windows, showing the creation of a new Group Policy Object under the 'techdirect.local' domain.
Screenshot of Group Policy Management interface displaying a dialog box for creating a new Group Policy Object with the name 'AAD SSO'.

When the GPO is created. Right-click on it and select edit as shown below

Screenshot of Group Policy Management interface showing the 'AAD SSO' object with an 'Edit' option highlighted.

Edit the GPO and Configure the Site to Zone Assignment List

The steps below will be broken into two parts as shown as you will apply them both to the User Configuration.

Please see how to configure Pleasant Password MsSQL SSO, how to configure and use Pleasant Password RDP SSO, How to disable or enable automatic login from the sign-in screen in Windows, and how to fix “Errors associated with Pleasant Password RDP SSO and SSH SSO”.

1: Navigate to the User Configuration > Administrative Templates, Windows Components, Internet Explorer, Internet Control Panel, Security Page, and double click on the Site to Zone Assignment List to modify the values as shown below

Screenshot of Group Policy Management Editor highlighting the Security Page and Site to Zone Assignment List settings.
Browsers will not send Kerberos tickets to a cloud endpoint, like the Azure AD URL, unless you explicitly add the URL to the browser’s Intranet zone.

Click on Enabled to enable the policy and click on the show button as shown below

Screenshot of the Site to Zone Assignment List settings in Internet Explorer, showing options for enabling or disabling site assignments and comments about security zones.

This will open the show contents wizard as shown below.

A pop-up window titled 'Show Contents' for entering zone assignments, displaying two columns: 'Value name' and 'Value', with buttons for 'OK' and 'Cancel'.

You will have to populate the above image above with the following information below.

Value NameValue
login.microsoftonline.com3
aadg.windows.net.nsatc.net1
autologon.microsoftazuread-sso.com1
secure.aadcdn.microsoftonline-p.com1

In the end, the “Show Contents” window will look this way.

Note: Whenever a value is entered, a new line will be created.
Screenshot of a dialog box showing zone assignments for various Microsoft online domains, including their corresponding values.

Click on okay when you are done.

Note: If Seamless SSO is to be disabled for individual groups or users, the GPO must be turned to the Value 4 for these people.

Enable the GPO “Allow updates to the status bar via script“

When this is done, navigate one step backward or follow the path:

Computer Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page > Intranet Zone and set the Allow updates to the status bar via script entry to Enabled as shown below
Screenshot of the Group Policy Management Editor displaying Internet Zone settings with a focus on the option 'Allow updates to status bar via script.'

Now, you will have to link the GPO to the domain. There are various ways to do this.

You can drag and drop the GPO wherever OU you want to via the Group Policy Management Console. I want this to apply to domain-wide computers and as such, I will be linking it there.

But to be sure and never to make mistakes. I will recommend you click on the domain, OU, etc where you want to link the GPO as shown below.

Note: You can also create a GPO and link it here immediately. But this is not recommended if you do not know what you are doing.
Screenshot of the Group Policy Management window showing the option to link an existing GPO in the Domains section.

This will now open the Select GPO window. Select the GPO you wish to link and in my case AAD SSO and click on OK.

Screenshot of Group Policy Management window showing the 'Select GPO' dialog with options for different Group Policy objects, highlighting 'AAD SSO' and with a red arrow pointing to the 'OK' button.

Now, we have the policy linked to our domain as shown below.

Screenshot of the Group Policy Management console displaying the domain 'techdirect.local' with a focus on 'AAD SSO' and status details regarding Active Directory and SYSVOL replication.

Now you can run the GPO switch to update the policy immediately instead of waiting for the default 90 minutes.

Command Prompt window displaying the execution of the 'gpupdate' command on a Windows 10 system, indicating successful completion of computer and user policy updates.

Renew the Kerberos Decryption Key

Microsoft recommends rolling out the Kerberos Decryption Key at least every 30 days. This reduces the risk of spying on the Kerberos Decryption Key.

To renew the Kerberos Decryption Key of the AZUREADSSOACC computer account. You must first download the Azure AD PowerShell module from the PowerShell Gallery.

Start PowerShell as the administrator on the computer on which AD Connect is installed and run the following command.

Install-Module MSOnline
A screenshot of a command line interface displaying the installation process of the MSOnline module in PowerShell, with a progress bar indicating unzipping.

Note: You may get a prompt requesting you to confirm the installation of the module since its source is regarded as untrusted.

Pop-up warning for untrusted repository installation in a software interface, asking for confirmation to install modules from 'PSGallery' with highlighted 'Yes to All' button.

Import the module AzureADSSO.psd1

When this is done installing, navigate to this path via PowerShell “C:\Program Files\Microsoft Azure Active Directory Connect” to import the module AzureADSSO.psd1

A screenshot of a PowerShell window displaying commands related to importing a module for Azure Active Directory Connect.

Next, execute the “New-AzureADSSOAuthenticationContext” command as shown below.

This will open the console registration page as shown below “enter the credentials of an Azure administrator in the following window”.

Screenshot of Microsoft Azure login interface with fields for email, phone, or Skype, alongside command line messages related to Azure Active Directory Connect.

Enter the username and password

Microsoft Azure sign-in window with email input field and options for account creation and recovery.
Microsoft Azure login screen prompting for password input
Microsoft Azure account login prompt requiring additional information for account protection, with fields for email and options to continue or switch accounts.

Click on continue as shown above. Then you will be required to perform some security checks as shown below

Enter your phone number and the OTP that is sent to you and finally. Click on finish to complete the verification process.

Screenshot of a security verification process prompting users to choose a contact method. It displays fields for entering a phone number with the country code for Germany (+49) and options for receiving a verification code via SMS.
A security verification dialog box in German, prompting the user to enter a text message code sent to their phone. It includes input fields for the code and buttons labeled 'Abbrechen' (Cancel) and 'Überprüfen' (Verify).
Security verification prompt indicating a text message was sent to a phone number, with a completion button labeled 'Fertig.'

Next, run the command below. This checks which domains are stored and activated in the Seamless SSO tenant.

Get-AzureADSSOStatus
Screenshot of a PowerShell terminal displaying the command 'Get-AzureADSSOStatus' related to Microsoft Azure Active Directory Connect, showing JSON output indicating settings for domain verification.

Then run the command below and enter the credentials of a local domain administrator in the following window.

$passwd = Get-Credential
Screenshot of a command prompt window with a credential input dialog. The dialog displays fields for 'User name' and 'Password,' with 'techdirect|administrator' entered as the username.

Lastly, we will have to run the following command below to complete the update of the Decryption Key of the AZUREADSSOACC computer account.

Update-AzureADSSOForest -OnPremCredentials $passwd
Command line interface showing Azure Active Directory Connect operations, including locating and updating a computer account and confirming successful completion.
Note: If you have multiple domains or child-domains, This must be done for all domains configured for Seamless SSO regardless.

Ensure cloud policy is applied on the end devices in your organisation as shown below

Command prompt window displaying the execution of the 'gpupdate /force' command on Windows 10, indicating successful updates for computer and user policies.

Now, let’s perform some testing to ensure single sign-on (PTA) works. Before proceeding with this test, ensure the user is properly sync and available on Azure AD.

See this guide for how this is achieved via Pass-Through Authentication. Also, see how to install and Configure Rancid, how to administer LXC Containers, how to remove a failed Edge Transport, and How to enable SSH access on Ubuntu server.

Test 1: Company network with company address

Follow these steps to test the Company network with the company address “https://myapps.microsoft.com/techdirectarchive.com“

A web browser tab displaying the Google homepage, with a search bar and a URL highlighting a specific link.

In this scenario, your PC is part of the domain in the corporate network that opens the following page via Chrome

Microsoft sign-in page displaying a loading message.
Microsoft account sign-in prompt requesting additional information for account security.

You are now granted access to the my-apps application without entering your password.

Please see how to fix We cannot sign you with this credential because your domain isn’t available: Make sure your device is connected to your organization’s network and try again.

Screenshot of the Microsoft Access Panel, displaying options for 'Groups' and 'Add-Ins' under the 'Apps' section.

Test 2 – Company network with normal web address

Follow these steps to test your Company network with the normal web address “https://myapps.microsoft.com/“

Screenshot of a web browser tab showing the URL 'myapps.microsoft.com' with Google logo in the background.

Here you will be required to enter an account or pick an existing account as shown below.

Microsoft account sign-in screen showing a list of accounts with one email selected.

Since I have an existing account, there is no need to enter a new account.

Microsoft sign-in page requesting more information to keep the account secure, with options to skip for 14 days, use a different account, or learn more.

Note: Your password will never be requested in this method. But you may be asked to perform additional security verification as shown below. I do not have the time to work you through this, have fun 😉

Screenshot of the Microsoft Additional Security Verification page, prompting users to select a contact method for verification, with options to receive notifications or use a verification code.
Screenshot of a Microsoft security verification process, showing steps to configure a mobile app with a QR code, setup instructions, and additional information for manual entry.

Here are some exciting articles: How to export PST from one Exchange Server to another server. How to fix PST Errors: The mailbox exceeds the maximum number of large items that were specified for this request.

Test 3 – Outside company network with company address

Outside company network with company address “https://myapps.microsoft.com/techdirectarchive.com“. In this example, you will be required to enter your username and password.

I hope you found this blog post helpful on how to fix SSO sign-in and non-routable domain issues. Now, you have learned how to fix SSO sign-in and non-routable domain issues leading to invalid usernames and passwords. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
AWS/Azure/OpenShift Tags:AD Connect, Azure, Azure AD, Azure AD Tenant, login, Microsoft Azure Active Directory, Slide, User Access, users

Post navigation

Previous Post: Fix VirtualBox Virtual Machine Encountered a Non-Fatal problem
Next Post: Error 0x801c001d – Automatic registration failed: Failed to look up the registration service from AD

Related Posts

  • AzureAD
    Azure Active Directory integration with on-premise AD using PTA AWS/Azure/OpenShift
  • MSSQL Always On Cluster on Azure
    [AZURE] Procedure for creating an MSSQL Always On Cluster on Azure AWS/Azure/OpenShift
  • cloudqueryfeature
    How to Manage Cloud Assets in AWS with CloudQuery AWS/Azure/OpenShift
  • S3 Bucket
    Access AWS Management Console and Create Resources with AWS CLI on Windows AWS/Azure/OpenShift
  • images 2 1
    How to create an AMI using AWS console AWS/Azure/OpenShift
  • Webp.net resizeimage 3 1
    How To Configure VM Update Management on Azure Stack Hub AWS/Azure/OpenShift

More Related Articles

AzureAD Azure Active Directory integration with on-premise AD using PTA AWS/Azure/OpenShift
MSSQL Always On Cluster on Azure [AZURE] Procedure for creating an MSSQL Always On Cluster on Azure AWS/Azure/OpenShift
cloudqueryfeature How to Manage Cloud Assets in AWS with CloudQuery AWS/Azure/OpenShift
S3 Bucket Access AWS Management Console and Create Resources with AWS CLI on Windows AWS/Azure/OpenShift
images 2 1 How to create an AMI using AWS console AWS/Azure/OpenShift
Webp.net resizeimage 3 1 How To Configure VM Update Management on Azure Stack Hub AWS/Azure/OpenShift

Comments (2) on “Fix SSO sign-in and non-routable domain issues”

  1. Avatar photo Tarhibit says:
    07/06/2022 at 9:21 AM

    I have found your content pretty helpful. Many thanks for sharing!

    Log in to Reply
    1. chris Christian says:
      13/06/2022 at 10:11 AM

      You are welcome!

      Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • 1723152 3cc3 2 750x405 1
    Cluster creation in Proxmox VE Virtualization
  • Update Wampserver
    How to update WampServer to Latest Version Web Server
  • PXE Boot Stuck or No Boot Image was found Te bootloader did not find any operating system
    Fix PXE Boot Stuck or No Boot Image was found for HyperV VM Virtualization
  • banner 1
    How to Hide or Block Wi-Fi Networks on Windows Network | Monitoring
  • windows pe screenshot1 rcm1200x0
    Workaround and Permanent fix for this snap-in performed a non-valid operation and has been unloaded: To continue using this snap-in restart MMC or try loading the snap-in again Windows Server
  • update powershell
    Fix WDAC vulnerabilities by updating PowerShell Security | Vulnerability Scans and Assessment
  • Featured image 1
    How to enable or disable color filters in Windows Windows
  • find my device banner
    Video on how to Enable Find My Device on Windows 11 Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.