Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

MDT deployment failed and Stuck at Command Prompt: Windows installation does not proceed via PXE boot

Posted on 07/10/202003/09/2026 Christian By Christian No Comments on MDT deployment failed and Stuck at Command Prompt: Windows installation does not proceed via PXE boot
  1. Home
  2. Windows Server
  3. MDT deployment failed and Stuck at Command Prompt: Windows installation does not proceed via PXE boot
MDT deployment

You may run into the following errors when you boot into MDT over PXE, nothing is being processed and rather, it fails at the command prompt (CMD). You can test this by entering “winpeinit” and if this does not work, then the WinPE has some issue. For more information on the differences between ADK, MDT, Microsoft Endpoint Configuration Manager (SCCM), Intune, Autopilot, and WSUS and how to fix No bootable media found system halted: Unable to PXE boot WDS to Virtualbox.

The Wpeinit.exe file communicates with the DHCP module and loads the resources needed to perform a network connection over TCP/IP. After the files have been processed, the boot process is complete and you can take advantage of the features of Windows PE. It can be used to installs Plug and Play devices, processes Unattend.xml settings, and loads network resources.

PXE boot

Please see WDS/DHCP related scenarios: How to configure DHCP Server option 60, 66, and 67 for Windows Deployment Services, Uninstall WDS: How to remove Windows Deployment Services role via the GUI and PowerShell.

MDT Share Replication Error

The reason for this error was because I replicated a share over the MDT to another. This means, I created a new share and copied the contents over one by one and some of the features were not correctly checked.

Note: In addition, These steps resolved my error and it might not be the same for you as there could be many other reasons for this. Follow the steps below to fix this issue. Right-click on the deployment share, and click on properties

Windows installation

– Select the WinPE Tab
– Select the features Tab
Here you will notice some features arent as shown below

Screenshot of a software interface displaying 'Feature Packs' options, including various language packs, storage enhancements, and Microsoft Data Access Components support.
Command Prompt

Under the Features, ensure the following are checked otherwise you will be stuck at the Command Prompt

- DISM Cmdlets
- Enhanced Storage
- winpe-fonsupport-winre
- .Net Framework
- Windows PowerShell
- Secure boot Cmdlets
- storage Management Cmdlets
- And finally click on Apply and then on OK.
Screenshot of a software interface displaying feature packs for Windows PE including options for various language packs and system components like Windows PowerShell and .NET Framework.
Screenshot of a software settings window showing feature packs for Windows PE, including options for language packs, .NET Framework, and various features like DISM Cmdlets and Enhanced Storage.

Optimizing PXE Boot Settings

Also On the General Tab, ensure the "Scratch space size" is set to your desired value".Other areas you should check are as follow to ensure a smooth PXE boot operation.

  • Furthermore, Ensure you have the right drivers needed for the WinPE to work.
  • If you use a “Selection Profile” for a specific driver, ensure this is tied to your deployment share.
  • Ensure you have the right boot Image, “Lite Touch Image” generated and placed in WDS.
  • Ensure you are using the right ADK version with MDT.
  • Ensure all needed DeploymentShare rules are in place and the task sequence is modified to reflect your deployment Share (environment) need.

However, Here are some related errors you will come across when modifying Windows Image. How to fix error 0xc1510114: The wim file needs to be remounted, error 0x80070002: When trying to mount an image file, error code 15601: 

Here is how to resolve DISM unspecified error when removing preinstalled packages, error 0xc1420127: The specified image in the specified wim is already mounted for read and write access.

I hope you found this blog post helpful. Moreover, Please let me know in the comment session if you have any questions.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Microsoft Deployment Toolkit (MDT), Windows 10, Windows Deployment Services, Windows Server 2016

Post navigation

Previous Post: Error 183: Specified image is being serviced by another DISM operation
Next Post: MDT Warning: Unable to set working directory, the application returned an unexpected code 2

Related Posts

  • Capture
    An account with the same name exists in Active Directory: Re-using the account was blocked by a security policy Security | Vulnerability Scans and Assessment
  • WDS server unable to start with Error Information 0xFFFFFDF0
    WDS server unable to start with Error Information 0xFFFFFDF0 Windows Server
  • a3a5a8be58fa09468cd4f70d36869e98
    Restore AD Objects: How to restore deleted user accounts in Active Directory with Microsoft LDP and PowerShell Windows Server
  • windows 10 creators update wallpaper 1
    How to locate and edit the host file on Windows Windows Server
  • sdf
    What is GPO and how can it be launched in Windows Windows Server
  • article 1280x720.192a2586 1 1
    How to install WSL on Windows Server Windows Server

More Related Articles

Capture An account with the same name exists in Active Directory: Re-using the account was blocked by a security policy Security | Vulnerability Scans and Assessment
WDS server unable to start with Error Information 0xFFFFFDF0 WDS server unable to start with Error Information 0xFFFFFDF0 Windows Server
a3a5a8be58fa09468cd4f70d36869e98 Restore AD Objects: How to restore deleted user accounts in Active Directory with Microsoft LDP and PowerShell Windows Server
windows 10 creators update wallpaper 1 How to locate and edit the host file on Windows Windows Server
sdf What is GPO and how can it be launched in Windows Windows Server
article 1280x720.192a2586 1 1 How to install WSL on Windows Server Windows Server

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Synology Diskstaion update to latest version 7.3
    Download and update Synology DiskStation NAS to DSM 7.3 Storage
  • install ssl certificate
    Configure SSL connection for WSUS Upstream and Downstream Servers Windows Server
  • PSD
    PowerShell Deployment Extension for MDT: How to deploy Windows using PSD, Microsoft Deployment Toolkit, and Windows Deployment Services Windows Server
  • How to Hide or Fix HP Printer Updates Windows Error 0x800f020b
    Hide Windows Updates: How to Hide or Fix HP Printer Windows Updates Error 0x800f020b Windows
  • ADBA for Windows
    Configure Active Directory-Based Activation (ADBA) for Windows Windows Server
  • Microsoft Office 365 Family
    Download Microsoft Office 365 Family Invoice for tax reasons Microsoft Exchange/Office/365
  • banner 2
    How to Configure and Run Performance Tests in Postman Automation
  • sql server installation
    How to Install all Editions of Microsoft SQL Server 2025 Oracle/MSSQL/MySQL

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.