Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Configure log on as a batch job permissions on any server

Posted on 16/03/202123/08/2026 Christian By Christian No Comments on Configure log on as a batch job permissions on any server
  1. Home
  2. Windows Server
  3. Configure log on as a batch job permissions on any server
Server permission settings

Log on as a batch job. This security setting allows a user to be logged on by means of a batch-queue facility and is provided only for compatibility with older versions of Windows. For example, when a user submits a job by means of the task scheduler, the task scheduler logs that user on as a batch user rather than as an interactive user. Default: Administrators and Backup Operators. Please visit the following links for more on Group Policy Objects and GPO. In this article, we shall discuss how to configure log on as a batch job permissions on any server.

I needed to grant an MBAM read only server “MBAM-RO-SVC” logon as a batch job permission and because of this, I decided to create this article for you to benefit from it. This is an MBAM Read-only service account which will have access to the reports area of the Administration and Monitoring Website.

You may need to configure “log on as a batch job” because the task scheduler job needs to run regardless of whether a user is logged on or runs in the background without opening a user session.

To learn more about these switches, see “All about GPUpdate Switches: GPUpdate vs GPUpdate /force“, what is Registry Editor and how to access the registry hives, and how to search through Windows Registry, what is Registry Editor and how to access the registry hives and how to search through Windows Registry.

Why do we need this settings configured?

As a result, the account used must be enforced or required for interactive logon, and this configuration is necessary. Please take a look at this link for more information.

For Scheduled Task as shown below, the scheduled task requires the “Log on as a batch job” right for a service account because this permission allows the account to run tasks in the background without interactive logon, which is essential for executing scheduled tasks.

logon as batch job

In the context of MBAM, The Log on as a batch job permission is required for the IIS account in MBAM (Microsoft BitLocker Administration and Monitoring) setup because it allows background processes to run under a specific account without requiring interactive logon. This is essential for web applications and services that need to execute automated tasks such as encryption key management and reporting.

During MBAM setup, IIS hosts web applications that facilitate BitLocker administration, including self-service portals and monitoring tools. These applications often rely on scheduled tasks or background processes to function correctly. And granting the IIS account the Log on as a batch job right ensures that these tasks can run securely and efficiently.

Please see Unable to run downloaded Programs due to Defender SmartScreen, how to retrieve Recent Windows Update: How to create batch script files, and how to Manage Microsoft Defender Antivirus with Argon ACMP.

Configure log on as a batch job permissions on any server

To fix this, search for the “secpol.msc” from the windows search as shown below. Alternatively, launch the run dialog wizard and enter “secpol.msc” and hit ok. Regardless of the step, you chose to use, this will open the Local Security Policy console. “

Note: You can also access this from the Group Policy Management Editor dialog box, under Computer Configuration, expand Policies, Windows Settings, Security Settings, and Local Policies, and then click User Rights Assignment

Batch job access control
If you configure the Log on as a batch job setting using domain-based Group Policy settings. The computer cannot assign the user right to accounts used for scheduled jobs in the Task Scheduler.

Locate the Local Policies, and then click User Rights Assignment. On the right pane of the window, double-click on log on as a batch job

Server user privileges

This will open up the Log on as a batch job Properties window. Click on Add Users or Group as shown below.

Note: When the log on as a batch job is grayed out, ensure to add your account as a member of the local administrator group on the PC.

Logon rights configuration

This will open up the wizard below to select users, computers, service accounts or groups. Here is how to fix “Error 1385: The user has not been granted the requested logon type at this time“.

Since we are interested in adding an MBAM service account, when I am done, I will click on OK.

Logon rights configuration

As you can see, the service account has been added. Click on Ok to close this window.

Screenshot-2021-03-16-at-22.15.59

As you can see the policy has been configured and that is all that needs to be done.

Screenshot-2021-03-16-at-22.16.52

Please, see Batch rename multiple files on Windows. Also, see the different Windows Logon Types, and how to Fix missing path and delete a Veeam Backup Repository.

FAQs

Why does my Scheduled Task succeed for .txt files but fail for .pdf, .png, or modifying spaces in a .csv file, even with modify rights and inherited folder permissions?

This is because the non-admin account lacks elevated privileges or access to specific apps or system components required to handle .pdf, .png, or .csv operations. Tasks run successfully under local admin accounts due to broader permissions and elevated access.

Why does a Scheduled Task require the “Log on as a batch job” right for a service account?

The “Log on as a batch job” right allows the service account to run tasks in the background without interactive logon.

I hope you found this blog post helpful on how to configure log on as a batch job permissions on any server. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Windows Server Tags:Permission, Windows 10

Post navigation

Previous Post: Unable to locate the account: Fix call to DsGetDcNameWithAccount failed with return value 0x0000054B
Next Post: How to alter a DATABASE compatibility level

Related Posts

  • group policy 1280x720 1
    Error: The processing of Group Policy failed because of lack of network connectivity to a DC. This may be a transient condition. A success message would be generated once the machine gets connected Windows Server
  • HighA
    Virtual Machine Scale Set: Demonstrating High Availability in Azure AWS/Azure/OpenShift
  • Screenshot 2021 02 05 at 19.09.17
    Install and update PowerShell version 7 on Windows and Linux Scripts
  • FIX RDP Authentication Error
    Fix Remote Connection Issue: An Authentication Error Has Occurred with Code 0x80004005 Windows
  • VBscript fixed and working in WinPE
    Windows PE working for Windows 11 and Windows Server 2022 Windows Server
  • GitLab runner update and upgrade
    How to update Gitlab-runners on Windows Windows

More Related Articles

group policy 1280x720 1 Error: The processing of Group Policy failed because of lack of network connectivity to a DC. This may be a transient condition. A success message would be generated once the machine gets connected Windows Server
HighA Virtual Machine Scale Set: Demonstrating High Availability in Azure AWS/Azure/OpenShift
Screenshot 2021 02 05 at 19.09.17 Install and update PowerShell version 7 on Windows and Linux Scripts
FIX RDP Authentication Error Fix Remote Connection Issue: An Authentication Error Has Occurred with Code 0x80004005 Windows
VBscript fixed and working in WinPE Windows PE working for Windows 11 and Windows Server 2022 Windows Server
GitLab runner update and upgrade How to update Gitlab-runners on Windows Windows

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • ext
    The DriveLock server returned an invalid or unrecognized response Security | Vulnerability Scans and Assessment
  • 1237968 3d79
    How to perform sysprep in Windows Windows
  • Capture 91
    How to install IIS Web Server on Windows Server Web Server
  • mssql
    Fix MSSQL Connection timeout and timeout period expired Oracle/MSSQL/MySQL
  • You are currently signed in as
    How to fix “You are currently signed in as: Use a different account-this account is managed by your organization” Microsoft Exchange/Office/365
  • Check Hard Drive Health (SMART) in Windows
    How to check Hard Drive Health (SMART) in Windows Windows
  • backu
    Wbadmin: How to stop Windows backup job via the Windows Server Backup utility Backup
  • images 8
    Microsoft Direct Access: Now Always On VPN Windows Server

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.