Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found

Posted on 07/03/202411/08/2026 Christian By Christian No Comments on Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found
  1. Home
  2. Virtualization
  3. Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found
SCSI-Controoler-HyperV-issue-failed-to-start-VM

Encountering an error with the message “The application encountered an error while attempting to change the state of VM” can have various causes. How the VM was set up is required to fix this issue. In this article, I will be showing you how to fix “Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found”. Please see The logon attempt failed for the remote desktop connection. Also, see how to fix “Norton Autofix identified an issue: Fix Norton 360 Installation has encountered an error 8404 on Windows“.

HyperV lets you create and run a software version of a computer, called a virtual machine. Each virtual machine acts like a complete computer, running an operating system and programs.

Here is how to set up a VM via PXE boot on a Generation 1 VM. Learn how to set up a VM via PXE boot on a Generation 2 VM. Here is how to deploy images to computers or virtual machines using WDS very interesting. Learn how to fix Windows deployment cannot continue, the operating system is missing via MDT deployment“.

Reason for “The Application encountered an error while attempting to change the state of VM”

The error “A virtual machine disk support provider for the specified file was not found” in Hyper-V occurs when there is an issue with the virtual machine’s disk configuration. Or when when Hyper-V is unable to find the necessary components to handle the specified virtual machine disk file as it is in my case.

More specifically, The system continued to utilize the SCSI controller because the ISO Image remained associated.

synthetic-scsi-controller

Here is how to fix “The following error occurred attempting to rename the computer Account already exists“, how to disable Windows Hardware Power Button, and How to Fix Boot Failed UEFI SCSI Device on HyperV.

Solution

To fix this issue, I will have to access the Virtual Machine Settings, Expand the SCSI Controller and click on DVD. On the right pane of the Window, I will select None and click on Apply or OK.

SCSI-controller

Do not forget to Remove the Virtual CD/DVD drive

remove-virtual-cd-dvd-drive

We have disassociated the DVD Drive from the SCSI Controller

SCSI-removed

Click Ok. Our VM should be able to boot properly.

Boot-order

Click start to start the VM.

VM-started

Enter your password to access your VM.

Login-to-VM

I hope you found this article useful on “Failed to Power on with Error ‘A virtual machine disk support provider for the specified file was not found”. Please feel free to leave a comment below.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization Tags:Microsoft Windows, Windows 10

Post navigation

Previous Post: Setup a Domain Controller as Recommended by Microsoft
Next Post: Video on how to Download and Use KiTTY SSH Client on Windows

Related Posts

  • How to Migrate Windows Servers from Hyper V to Proxmox Correctly
    Migrate Windows Servers from Hyper V to Proxmox Correctly Backup
  • hero windowsserver hyperv scaled
    Why does the legacy PXE not does work on Generation 2 VM Virtualization
  • 87a26c60 0001 0004 0000 000001423515 w948 r1.77 fpx54.99 fpy56.04
    Administer LXC Containers: Easy Guide Virtualization
  • VMware Tech Showcase
    Great details on VMware Tech Showcase Virtualization
  • Azure Local New Policy fix
    How to Resolve New WDAC Policy Issues in Azure Stack Virtualization
  • OxscsIP
    Enable Virtualization in Windows: Fixing VirtualBox’s 32-bit Option Virtualization

More Related Articles

How to Migrate Windows Servers from Hyper V to Proxmox Correctly Migrate Windows Servers from Hyper V to Proxmox Correctly Backup
hero windowsserver hyperv scaled Why does the legacy PXE not does work on Generation 2 VM Virtualization
87a26c60 0001 0004 0000 000001423515 w948 r1.77 fpx54.99 fpy56.04 Administer LXC Containers: Easy Guide Virtualization
VMware Tech Showcase Great details on VMware Tech Showcase Virtualization
Azure Local New Policy fix How to Resolve New WDAC Policy Issues in Azure Stack Virtualization
OxscsIP Enable Virtualization in Windows: Fixing VirtualBox’s 32-bit Option Virtualization

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • Screenshot 2021 02 05 at 19.09.17
    Install and update PowerShell version 7 on Windows and Linux Scripts
  • images 5
    Perform Pleasant Password Self-Service Reset Enrolment Password Manager
  • Screenshot
    Change Active Directory Domain name from dot local to dot com Windows Server
  • Screenshot 2020 09 19 at 02.22.42
    Remove Windows 10 Apps with DISM: How to remove pre-provisioned apps from Windows Image Windows Server
  • PNG JPGconversion 2
    How to change the default screen capture format in macOS Mac
  • windows 11 desktop 1
    Hardware and Software Requirements: Upgrade to Windows 11 Windows
  • FEATURE IMAGE BASE URL 1
    How to solve cannot find a valid base URL for repo: base/7/x86_64 Linux
  • microsoft warns windows 10 cumulative update kb4494441 breaks down some websites 526066 2
    Launch an application automatically during startup on Windows Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,759 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.