Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

IP Address UNREACHABLE: HTTP connection pool Max exceeded

Posted on 17/04/202007/09/2026 Christian By Christian 4 Comments on IP Address UNREACHABLE: HTTP connection pool Max exceeded
  1. Home
  2. Configuration Management Tool
  3. IP Address UNREACHABLE: HTTP connection pool Max exceeded

In this article, you will learn how to fix the following error “IP Address UNREACHABLE: HTTP connection pool Max exceeded’. Ansible is an open-source software provisioning, configuration management, and application-deployment tool enabling infrastructure as code. Please see how to deploy a React Application to AWS S3, and how to deploy a .NET application to AWS Elastic Beanstalk using AWS Tool Kit.

Other helpful tutorials can be found here: Amazon Relational Database Service: How to install Amazon RDS using Terraform. How to install PostgreSQL on Ubuntu, and how to install, configure Prometheus for Monitoring on a Linux Server.

Why was the Error “IP Address UNREACHABLE” Prompted?

The following error below is a result of a wrong IP Address used in the inventory list. For more information on Ansible authentication options, see the following guides on Kerberos and WinRM Options.

Error as shown in the image below ” IP Address UNREACHABLE: HTTP connection pool Max retries exceeded with url/wsman caused by NewConnectionError”

Since my focus is on Kerberos, see the article on how to configure Kerberos

192,168,178.43 | UNREACHABLE! => {
"changed": false,
"msg": "ssl: HTTPSConnectionPool(host='192,168,178.43', port=5986): Max retries exceeded with url: /wsman (Caused by NewConnectionError(': Failed to establish a new connection: [Errno 8] Name or service not known'))",
"unreachable": true
}

The solution

To fix the IP Address UNREACHABLE: HTTP connection pool Max retries exceeded with url/wsman caused by NewConnectionError

As you can see, it clearly stated “NewConnectionError”. Failed to establish a new connection because the IP Address had a comma (,) instead of a dot (.) in the host inventory as shown below.

Correct the inventory file as shown above. With the right IP Address and try again and try to oing the host inventory file as shown below with the following Ad hoc command.

$ ansible all -i hosts -m win_ping

I hope you found this blog post on ‘IP Address UNREACHABLE: HTTP connection pool Max exceeded” very helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Configuration Management Tool Tags:API IP unreachable connection timeout Python, Configuration Management Tool, fix requests connection pool max size exceeded, fix urllib3 connection pool error, HTTPConnectionPool max retries exceeded error fix, IP Address, IP address unreachable HTTP connection pool max retries exceeded, network connectivity HTTP request error fix, Python requests connection error troubleshooting, server unreachable HTTP request failure, Windows 11

Post navigation

Previous Post: Ansible_user=UNREACHABLE {Failed to connect to the host via SSH: SSH: Could not resolve hostname (Name or service not known, unreachable true)
Next Post: How to configure a remote Windows Server to Support Ansible

Related Posts

  • images 1
    WARNING: The provided hosts list is empty only the localhost is available and note that the implicit localhost does not match all Configuration Management Tool
  • 1 ifg3ir3l 8ejus3pueqt0a
    Fix cannot find KDC for realm while getting initial credentials and kinit configuration file does not specify default realm Configuration Management Tool
  • Create S3 Bucket with Terraform
    Create an S3 Bucket with Terraform AWS/Azure/OpenShift
  • images 7
    The plugin filter file/etc/ansible/plugin_filters(yml) does not exist – Skipping Configuration Management Tool
  • ansiblebanner
    Install and configure Ansible on Azure Virtual Machine Configuration Management Tool
  • ansible 1
    How to fix no Python interpreters found for the host Configuration Management Tool

More Related Articles

images 1 WARNING: The provided hosts list is empty only the localhost is available and note that the implicit localhost does not match all Configuration Management Tool
1 ifg3ir3l 8ejus3pueqt0a Fix cannot find KDC for realm while getting initial credentials and kinit configuration file does not specify default realm Configuration Management Tool
Create S3 Bucket with Terraform Create an S3 Bucket with Terraform AWS/Azure/OpenShift
images 7 The plugin filter file/etc/ansible/plugin_filters(yml) does not exist – Skipping Configuration Management Tool
ansiblebanner Install and configure Ansible on Azure Virtual Machine Configuration Management Tool
ansible 1 How to fix no Python interpreters found for the host Configuration Management Tool

Comments (4) on “IP Address UNREACHABLE: HTTP connection pool Max exceeded”

  1. Avatar photo Dan says:
    02/08/2022 at 3:34 PM

    I have been having a lot of trouble with the Windows AMI builds. We use a AWS code build server that we load packer and Ansible on to connect and configure the AMI’s. 

    I am having a problem with winrm connection time outs, especially after reboots.  

    CONNECTION FOR USER: Administrator on PORT 5986 TO 10.184.8.21
       amazon-ebs: fatal: [default]: UNREACHABLE! => {
       amazon-ebs:    “changed”: false,
       amazon-ebs:    “msg”: “basic: HTTPSConnectionPool(host=’10.184.8.21′, port=5986): Max retries exceeded with url: /wsman (Caused by ConnectTimeoutError(<requests.packages.urllib3.connection.HTTPSConnection object at 0x7f893732dd50>, ‘Connection to 10.184.8.21 timed out. (connect timeout=30)’))”,
       amazon-ebs:    “unreachable”: true
       amazon-ebs: }
       amazon-ebs:
       amazon-ebs: PLAY RECAP 
    Is there a way to increase this time to 90 and add the number of tries? I added a pause after the reboot, this seems to help, but it still is not consistent. This timing delicacy is my main problem working with Windows AMI’s. If I change the order of the tasks, or and executable changes the whole thing breaks.

    Log in to Reply
    1. chris Christian says:
      03/08/2022 at 3:09 PM

      [ansible-project] Re: Problem with WinRM Connections (mail-archive.com)

      Log in to Reply
  2. Avatar photo Shashikant Ngare says:
    15/03/2023 at 12:48 PM

    I have struggled for 2 days with same issue , and while googling got his page , tried the solution and it got worked …

    Thanks …….

    Log in to Reply
    1. chris Christian says:
      15/03/2023 at 2:42 PM

      Thanks, a lot for your feedback! I am glad you found it useful…

      Log in to Reply

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • How to use Netstat.exe to confirm which Program uses or blocks a port
    How to use Netstat.exe to confirm which Program uses or blocks a port Linux
  • annoying startup apps
    Stop an application from starting up automatically on macOS Mac
  • Veeam App for Splunk setup
    Install Splunk and Veeam App on Windows Server to monitor VBR Backup
  • Banner 1 e1781003668538
    How to Assign a Public IP to Azure Virtual Machine (VM) AWS/Azure/OpenShift
  • centos feature
    How to change the system time zone under RedHat and CentOS Linux
  • BitLocker
    BitLocker Drive Encryption architecture and implementation types on Windows Windows Server
  • Preliminary Active Directory Analysis
    Preliminary Guide for Active Directory and Initial Assessment Network | Monitoring
  • Disable Hardware Acceleration in Browsers and Windows
    How to Disable Hardware Acceleration in Browsers and Windows Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.