Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

How to license Veeam Enterprise Manager and Add VBR Servers

Posted on 03/03/202623/06/2026 Christian By Christian No Comments on How to license Veeam Enterprise Manager and Add VBR Servers
  1. Home
  2. Backup
  3. How to license Veeam Enterprise Manager and Add VBR Servers
VBEM Licensing And Backup Server

Veeam Backup Enterprise Manager (VBEM or VEM) centralizes the management and reporting of multiple Veeam Backup & Replication servers through a single web-based console. It enables organizations to oversee distributed backup infrastructures efficiently, whether in remote office/branch office (ROBO) environments or large-scale enterprise deployments. In this article, we shall discuss How to license Veeam Enterprise Manager and Add VBR Servers. Please, see Run Mendeley Reference Manager and Cite for Word on Windows, and how to run Mendeley Reference Manager and Cite for Word on Windows.

Instead of managing each backup server separately, administrators use Enterprise Manager as a unified control point. From one interface, they distribute and monitor licenses, create and manage backup jobs and policies, review performance and operational statistics, and initiate restore operations.

By consolidating visibility and control, Enterprise Manager simplifies administration, improves operational efficiency, and provides a comprehensive overview of the entire virtual backup environment.

Also, see How to update Veeam Backup and Replication [VBR], Install Veeam ONE and Add VBR: Fix failed to connect to VBR, and how to Fix Error 1069: Windows could not start the Veeam backup service on local computer.

Installing VBEM License

Veeam Backup Enterprise Manager allows you to control license distribution. It also helps in managing jobs and policies across the backup infrastructure, analyze operation statistics of Veeam backup servers, perform restore operations, and so on.

Before adding VBR to VBEM. It is important and valid to install a valid license as shown below as it help reduces administration overhead. This is because, Veeam Backup & Replication infrastructure requires a license to process backup and replication jobs.

To install a license. Please, sign in to Veeam Backup Enterprise Manager using an account with the Portal Administrator role. Then, navigate to the Configuration View as shown below.

In the Configuration view, open the Licensing section and click on Summary. Here, click on “Install License”. Select the necessary LIC file and click Open.

Install License

License will be installed and will scan for updates to VBEM (VEM). You will be prompted to apply the patch. Click on Yes.

Install Updates

As you can see, the updates are being applied.

Installing Updates

System correctly patched as shown in the images below.

Vbem Uptodate
Update History
Updater Settings

Note. You can request an NFR license via the following program, as discussed here: “How to apply and install Veeam NFR License“. Alternatively, you can also request a Trial Key from here.

Viewing License Details

Now, let’s take a look at the licensing summary. You can view information about the license edition, license state and a spreadsheet of the available and used instances per each type of protected workloads: Microsoft Entra tenants, virtual machines, physical servers and physical workstations, cloud machines, applications, file shares.

Note: When you run a job, Enterprise Manager uses instances required for each type of protected workloads for per-instance licenses or applies a license to the protected hosts for per-socket licenses. If a workload is protected by multiple backup servers added to the Enterprise Manager infrastructure, the workload will consume the Enterprise Manager license only once.

In the next guide, I will show you how configure Veeam Backup Enterprise Manager to send notifications about expiring license.

You can also display detailed information about the current license, including license type, expiration date and the number of instances. To do this, click the Details link. To view information about license usage, click the Report link.

License Summary
Note: Veeam Backup Enterprise Manager does not display information about instances consumed in the Veeam Cloud Connect service provider license by tenant workloads. This information is available only on the backup server of the service provider

Please, see How to set up Devolusion Remote Desktop Manager on Windows, Veeam Enterprise Manager setup and User Role management, and how to upgrade Windows Admin Center from v2411 to v2511.

Add Veeam Backup and Replication to Veeam Enterprise Manager

Note: Below are the few things to note when adding a Backup server to VBEM. Enterprise Manager uses Kerberos authentication to communicate with backup servers. You cannot add a backup server that is running a newer version than Enterprise Manager. The Enterprise Manager version must be equal to or later than the version of any backup server you add. Before adding a backup server of a newer version,

Enterprise Manager supports adding backup servers running Veeam Backup & Replication 12.3 or later. When Enterprise Manager and Veeam Backup & Replication run different major or minor versions, some Enterprise Manager features may not be available.

Enterprise Manager does not support editing jobs that are managed by backup servers of earlier major or minor versions. This includes Veeam Agent backup jobs, file backup jobs, object storage backup jobs, and backup copy jobs

To add a backup server that is part of a High Availability (HA) cluster. Add it using the cluster virtual IP address or cluster full DNS name. In this case, after a node switchover, Enterprise Manager will automatically collect the data from the active node. If a backup server that is already added to Enterprise Manager becomes part of an HA cluster. You must re-add it using the cluster virtual IP address or cluster full DNS name after assembling the cluster. If you do not re-add the backup server, Enterprise Manager will not be able to collect data from it after a node switchover

Do not add the same backup server to multiple instances of Enterprise Manager, as well as a backup server cloned from an already added backup server.

Do not add a backup server that holds the same configuration database as an already added backup server, even after you remove the original backup server from Enterprise Manager.

Adding a Backup Server

To do this, log into the VBEM, and navigate to the Configuration view, click Configuration in the upper-right corner.

Configuration VBEM

Select the Backup Servers section on the left of the Configuration view, and click on Add.

Add Backup Server

Click on Yes to the warning below.

Warning

Ignore the arrow below, we will be adding the VBR server here. Therefore, select Veeam Backup and Replication, and enter the IP or DNS name followed by the credentials.

Deploy Agent To VBEM

On the Backup Server Settings, click on OK

Server Settings

Note: If you are having connection issues and port 443 is being highlighted. This could be because, some Veeam services are not running. Please, see similar error discussed here “Deploy Veeam Recovery Orchestrator and Agents to VBR and VEM“.

Ensure the services are started and please try to add the backup server again.

Services Not Running

Ensure all services are running and try to add the connection again.

Trust Server 1

As you can see, we have successfully added our Backup server (VBR) to VBEM (VEM).

VBR Added To VBEM

Now, you can exit the configuration.

Note: To keep information accurate and up to date, Enterprise Manager actively collects configuration data and job details from each connected backup server. It accomplishes this by running a scheduled data collection task that gathers information about backup jobs, infrastructure components, and system status, ensuring the console always reflects the current state of the environment.

VBEM Dashboard

I hope you found this article on how to license Veeam Enterprise Manager and Add VBR Servers very useful. Please, feel free to leave a comment below.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Backup Tags:add backup server to VBEM, Add backup Server to Veeam Enterprise Manager, license Veeam Enterprise Manager and add VBR servers, register backup server in Veeam Enterprise Manager, VBEM, VBR, Veeam Backup and Replication, Veeam Backup Enterprise Manager, Veeam Enterprise Manager multi-server management, VEM

Post navigation

Previous Post: How to upgrade Windows Admin Center from v2411 to v2511
Next Post: Inbound connection Error: Failed to Perform Scheduled Replication [Part 2]

Related Posts

  • Time machine
    How to Backup MacOS to Synology NAS via Time Machine Backup
  • Object First Honeypot OOTBI
    OOTBI Security Best Practices: Enable Honeypot on Object First Backup
  • Veeam ONE 13.1
    Veeam ONE 13.1.0.7034 Upgrade: Complete Pre-flight and Step-by-Step Guide Backup
  • Entra ID backup e1784558902170
    How to Back Up and Restore Microsoft Entra ID with Veeam Backup & Replication v13 AWS/Azure/OpenShift
  • Failed to open deployer Service Management Port e1782239184862
    Failed to Upgrade VIHR Component: Failed to open deployer Service Management Port Backup
  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift

More Related Articles

Time machine How to Backup MacOS to Synology NAS via Time Machine Backup
Object First Honeypot OOTBI OOTBI Security Best Practices: Enable Honeypot on Object First Backup
Veeam ONE 13.1 Veeam ONE 13.1.0.7034 Upgrade: Complete Pre-flight and Step-by-Step Guide Backup
Entra ID backup e1784558902170 How to Back Up and Restore Microsoft Entra ID with Veeam Backup & Replication v13 AWS/Azure/OpenShift
Failed to open deployer Service Management Port e1782239184862 Failed to Upgrade VIHR Component: Failed to open deployer Service Management Port Backup
OpenShift DR Hero e1784641900398 Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • dfgh
    How to install Pleasant Password Server Password Manager
  • fba7f screenshot 2019 04 15 at 18.33.30
    File System Overview: How to decide on the right File System to use for your USB Linux
  • featureunions
    How to Install Unison on Linux System Linux
  • Domain
    Connectivity to a writable domain controller from a node could not be determined because of an error Virtualization
  • Capture 37
    How to Configure Network Load Balancing on Windows Server Backup
  • VLC Media Player pcgh b2article artwork
    How to Set Quicktime or VLC as a default player on macOS Mac
  • Prevent the saving of RDP Credentials
    Prevent users from saving RDP Credentials on Windows 11 Windows
  • Untitled Design 25
    Setup Hyper-V via the Server Manager or PowerShell or DISM Virtualization

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,752 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.