Skip to content

TechDirectArchive

Hands-on IT, Cloud, Security, Veeam & DevOps

  • Home
  • About
  • Advertise With US
  • Reviews
  • Contact
  • Toggle search form

DNS Bad key 9017: The Cluster Name registration failed of one or more associated DNS names

Posted on 16/07/202122/08/2026 Christian By Christian No Comments on DNS Bad key 9017: The Cluster Name registration failed of one or more associated DNS names
  1. Home
  2. Virtualization
  3. DNS Bad key 9017: The Cluster Name registration failed of one or more associated DNS names
DNS Key 9017 Error

Active Directory Domain Services (AD DS) uses Domain Name System (DNS) name resolution services to make it possible for clients to locate domain controllers and for the domain controllers that host the directory service to communicate with each other. AD DS enables easy integration of the Active Directory namespace into an existing DNS namespace. Features such as Active Directory-integrated DNS zones make it easier for you to deploy DNS by eliminating the need to set up secondary zones, and then configure zone transfers.

Kindly refer to the following related guides: How to setup a cache-only DNS server, how to locate and edit the hosts file on Windows, how to install RSAT tools: DNS manager console missing from RSAT tools on Windows 10, how to setup SPF and TXT Records in AWS, how to add and verify a custom domain name to Azure Active Directory, Active Directory: How to Setup a Domain Controller, how to locate and edit the host file on macOS, and how to know when an IP or domain has been blacklisted.

When you first create a cluster, Hyper-V creates a Cluster network name resource for use in identifying your cluster via DNS. Also, a DNS record for the static IP address of the cluster is created in AD DNS. Here is a similar error that you might encounter: Failover Cluster Manager failed while managing one or more clusters, the error was unable to determine if the computer exists in the domain.

Problem – Invalid DNS Entry:

Physical nodes must update the cluster name resource added to DNS before setting up an active-passive cluster. When the active node owns the resources it want to update the A record in the DNS database and DNS record which was created won’t allow any authenticated user to update the DNS record with the same owner.

  • Follow the solution recommended below and ensure the “Allow any authenticated user to update DNS records with the same owners name” is checked. Here is a similar error: Domain Name System: How to create a DNS record. To fix this issue, you will have to delete you the DNS record your precreated for the cluster node in order to associate the “Allow any authenticated user to update DNS records with the same owners name”. Below are the associated error for your information only.
DNS Name Resolution Issue
Screenshot 2021 07 13 at 02.37.44
Cluster Name Registration Failure
Screenshot 2021 07 13 at 02.44.20

Furthermore, Select the specic record and right click on it. Select Delete to delete the DNS record previously created.

DNS Error 9017

However, Confirm by clicking Yes that you want to delete the record as shown below.

DNS Key 9017 Error

DNS Bad key 9017: Accessing DNS Snap-In in Server Manager

To add an A record, kindly launch the DNS snap-in as shown below. From the Server Manager, click on Tools and then select Server Manager.
– Moreover, In the console tree, right-click the applicable forward lookup zone, and then click New Host (A or AAAA) as shown below. See this guide for the different types of DNS Records you can create. See this guide for more information: Domain Name System: How to create a DNS record

Cluster Name Registration Failure

Nonetheless, Ensure the “Allow any authenticated user to update DNS records with the same owners name.” Additionally, ensure you check ‘Create Associated PTR Record’ if you have configured the Reverse Arpa zone for automatic PTR record addition.
– Click on Add Host when you are done.

DNS Name Resolution Issue

Consequently, the record has been successfully created. Kindly refer to these troubleshooting guides for some insights: The following error occurred when DNS was queried for the service location (SRV): Error code 0x0000232B RCODE_NAME_ERROR, and the following errors occurred attempting to join the domain: The specified domain either does not exist or could not be contacted.

Screenshot-2021-07-13-at-03.25.42

The figure below shows the events clearing and errors no longer persist.

Screenshot-2021-07-13-at-03.47.10

Other Suggestions: To prevent “DNS Bad key 9017,” use internal DNS records only. Remove the external DNS address. Check that your DNS Server does not have any public DNS servers specified; for example 8.8.8.8 or 1.1.1.1

Screenshot-2021-07-13-at-00.53.20
Screenshot 2021 07 13 at 00.53.20
Screenshot-2021-07-13-at-00.53.46
Screenshot 2021 07 13 at 00.53.46
Lastly, if all the above mentioned steps do not work for you, please take your Cluster resource offline, run a repair!
- This will not affect your VMs.

I hope you found this blog post on DNS Bad key 9017 helpful. If you have any questions, please let me know in the comment session.

Thank you for reading this post. Kindly share it with others.

  • Share on X (Opens in new window) X
  • Share on Reddit (Opens in new window) Reddit
  • Share on LinkedIn (Opens in new window) LinkedIn
  • Share on Facebook (Opens in new window) Facebook
  • Share on Pinterest (Opens in new window) Pinterest
  • Share on Tumblr (Opens in new window) Tumblr
  • Share on Telegram (Opens in new window) Telegram
  • Share on WhatsApp (Opens in new window) WhatsApp
  • Share on Mastodon (Opens in new window) Mastodon
  • Share on Bluesky (Opens in new window) Bluesky
Virtualization Tags:DNS, DNSRecord, Microsoft Windows, Windows 10, Windows Server 2016

Post navigation

Previous Post: vSwitches: How to delete Virtual Switches from Hyper-V
Next Post: Connectivity to a writable domain controller from a node could not be determined because of an error

Related Posts

  • Burn ISO on MAC Proxmox installation
    Create a bootable USB on Mac: Proxmox VE Setup Virtualization
  • upgrade proxmox node e1781352297373
    How to update Proxmox VE to the latest version 9.2.3 today Virtualization
  • OpenShift DR Hero e1784641900398
    Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
  • Create Alarm
    How to create Alarm rules in VMware vSphere Virtualization
  • proxmox
    Clone a Proxmox Container: CT Restoration Guide Virtualization
  • Shrink and Compact Virtual Hard Disks
    How to Shrink and Compact Virtual Hard Disks in Hyper-V Virtualization

More Related Articles

Burn ISO on MAC Proxmox installation Create a bootable USB on Mac: Proxmox VE Setup Virtualization
upgrade proxmox node e1781352297373 How to update Proxmox VE to the latest version 9.2.3 today Virtualization
OpenShift DR Hero e1784641900398 Backing Up OpenShift Is Not the Same as Recovering It AWS/Azure/OpenShift
Create Alarm How to create Alarm rules in VMware vSphere Virtualization
proxmox Clone a Proxmox Container: CT Restoration Guide Virtualization
Shrink and Compact Virtual Hard Disks How to Shrink and Compact Virtual Hard Disks in Hyper-V Virtualization

Leave a Reply Cancel reply

You must be logged in to post a comment.

Microsoft MVP

vexpert-badge-stars-5

Virtual Background

VEEAMLEGEND

Categories

veeaam100

Veeam Vanguard

  • enable WinRM
    WSManFault Message 2144108526 0x80338012: Fix the client cannot connect to the destination specified in the request Windows Server
  • powershell
    How to install the Microsoft PSWindowsUpdate module silently Scripts
  • NFS Storage and Present it to XCP ng
    Create an NFS Storage on Synology NAS and Present it to XCP-ng Virtualization
  • retrieve SSL
    How to Retrieve an SSL Thumbprint in Windows using MMC Windows
  • Windows10 as a Service Waas
    Windows 10 Feature and Quality Updates Windows
  • Fix invalid backup repostory and delete not needed repo via Veeam Backup Repository
    Fix missing path and delete a Veeam Backup Repository Backup
  • Synology NAS as a Backup Repository for VBR
    Setup DS923+ Synology NAS as a Backup Repository for VBR Reviews
  • blog banner 1
    Reset and reinstall Windows from the cloud : Recover Windows when you cannot boot Windows

Subscribe to Blog via Email

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Join 1,757 other subscribers
  • RSS - Posts
  • RSS - Comments
  • About
  • Authors
  • Write for us
  • Contact
  • Advertise with us
  • General Terms and Conditions
  • Privacy policy
  • Feedly
  • Telegram
  • Youtube
  • Facebook
  • Instagram
  • LinkedIn
  • Tumblr
  • Pinterest
  • Twitter
  • mastodon
  • Bsky

Tags

Active Directory Azure Bitlocker Microsoft Windows PowerShell WDS Windows 10 Windows 11 Windows Deployment Services Windows Server 2016

Copyright © 2026 TechDirectArchive

Loading Comments...

You must be logged in to post a comment.